]> code.ossystems Code Review - openembedded-core.git/commitdiff
psplash_git.bb: fix do_compile by correcting the script path
authorNitin A Kamble <nitin.a.kamble@intel.com>
Wed, 27 Mar 2013 05:16:26 +0000 (22:16 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Mar 2013 11:06:58 +0000 (11:06 +0000)
The recent change in the builddir location is breaking this recipe as
it is trying to run a script (make-image-header.sh) located in sourcedir
from builddir. As the script does not gets to run, the resulting file is
not generated causing error as seen below. This commit fixes the issue, by
providing complete path of the script.

This commit fixes this build error:

ERROR: Error executing a python function in /srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb:
IOError: [Errno 2] No such file or directory: 'psplash-tlk-img.h'
ERROR: Task 6 (/srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb, do_compile) failed with exit code '1'

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/psplash/psplash_git.bb

index 5413b240575b1b9f01c0f8e0d48f5be791a588e8..2d0cae371dd39a7372157a7e7990c530db2f988f 100644 (file)
@@ -74,12 +74,13 @@ python do_compile () {
     import shutil, commands
 
     # Build a separate executable for each splash image
+    convertscript = "%s/make-image-header.sh" % d.getVar('S', True)
     destfile = "%s/psplash-poky-img.h" % d.getVar('S', True)
     localfiles = d.getVar('SPLASH_LOCALPATHS', True).split()
     outputfiles = d.getVar('SPLASH_INSTALL', True).split()
     for localfile, outputfile in zip(localfiles, outputfiles):
         if localfile.endswith(".png"):
-            outp = commands.getstatusoutput('./make-image-header.sh %s POKY' % localfile)
+            outp = commands.getstatusoutput('%s %s POKY' % (convertscript, localfile))
             print(outp[1])
             fbase = os.path.splitext(os.path.basename(localfile))[0]
             shutil.copyfile("%s-img.h" % fbase, destfile)