]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: mount and unmount cifs network filesystems
authorAndreas Oberritter <obi@opendreambox.org>
Fri, 24 Feb 2012 20:27:34 +0000 (21:27 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 24 Feb 2012 23:25:33 +0000 (23:25 +0000)
* Added cifs to mountnfs.sh and umountnfs.sh.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/initscripts/initscripts-1.0/mountnfs.sh
meta/recipes-core/initscripts/initscripts-1.0/umountnfs.sh
meta/recipes-core/initscripts/initscripts_1.0.bb

index 859fc9eb216d1534e045310944ee218a7d1518f6..82ec7f66eb6cd93e73e05c1aae7fe88af661562c 100755 (executable)
@@ -23,6 +23,7 @@ portmap=no
 mount_nfs=no
 mount_smb=no
 mount_ncp=no
+mount_cifs=no
 while read device mountpt fstype options
 do
        case "$device" in
@@ -56,6 +57,10 @@ do
        then
                mount_ncp=yes
        fi
+       if test "$fstype" = cifs
+       then
+               mount_cifs=yes
+       fi
 done
 
 exec 0>&1
@@ -70,12 +75,13 @@ then
        fi
 fi
 
-if test "$mount_nfs" = yes || test "$mount_smb" = yes || test "$mount_ncp" = yes
+if test "$mount_nfs" = yes || test "$mount_smb" = yes || test "$mount_ncp" = yes || test "$mount_cifs" = yes
 then
        echo "Mounting remote filesystems..."
        test "$mount_nfs" = yes && mount -a -t nfs
        test "$mount_smb" = yes && mount -a -t smbfs
        test "$mount_ncp" = yes && mount -a -t ncpfs
+       test "$mount_cifs" = yes && mount -a -t cifs
 fi
 
 ) < /etc/fstab
index 15d1f73131cdcad478d4cafe22fad73059ae7573..af075407fd40bfe6f88bd54dedc22a29170331d4 100755 (executable)
@@ -23,7 +23,7 @@ test -f /etc/fstab && (
 #
 while read device mountpt fstype options
 do
-       if test "$fstype" = nfs ||  test "$fstype" = smbfs ||  test "$fstype" = ncpfs
+       if test "$fstype" = nfs ||  test "$fstype" = smbfs ||  test "$fstype" = ncpfs || test "$fstype" = cifs
        then
                umount -f $mountpt
        fi
index b56c55c8a56c73559d72c4f6156d7e56d93e3f4b..e16f19f1ada3b7819f1bdeaf7ae8d858002f5d05 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Initscripts provide the basic system startup initialization scrip
 SECTION = "base"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PR = "r130"
+PR = "r131"
 
 INHIBIT_DEFAULT_DEPS = "1"