]> code.ossystems Code Review - openembedded-core.git/commitdiff
zlib: Clean up recipe and use BBCLASSEXTEND for native and sdk versions
authorRichard Purdie <rpurdie@linux.intel.com>
Sat, 3 Jan 2009 17:31:17 +0000 (17:31 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Sat, 3 Jan 2009 17:31:17 +0000 (17:31 +0000)
meta/classes/native.bbclass
meta/packages/zlib/zlib-native.inc [deleted file]
meta/packages/zlib/zlib-native_1.2.3.bb [deleted file]
meta/packages/zlib/zlib-sdk.inc [deleted file]
meta/packages/zlib/zlib-sdk_1.2.3.bb [deleted file]
meta/packages/zlib/zlib_1.2.3.bb

index 9f6501f583a57c6f3c45d83beac8f35ed841769d..077ac9c8a3397b9c17f1d059e133d3c57a82e7ff 100644 (file)
@@ -105,6 +105,12 @@ python __anonymous () {
     else:
         autoextend = False
     for dep in deps:
+        if dep.endswith("-cross"):
+            if autoextend:
+                depends = depends.replace(dep, dep.replace("-cross", "-native"))
+            else:
+                bb.note("%s has depends %s which ends in -cross?" % (pn, dep))
+
         if not dep.endswith("-native"):
             if autoextend:
                 depends = depends.replace(dep, dep + "-native")
diff --git a/meta/packages/zlib/zlib-native.inc b/meta/packages/zlib/zlib-native.inc
deleted file mode 100644 (file)
index 2228710..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-ZLIB_EXTRA = ""
-inherit native
-
-do_stage() {
-        install -m 0644 zlib.h ${STAGING_INCDIR}/
-        install -m 0644 zconf.h ${STAGING_INCDIR}/
-        install -m 0644 zlibdefs.h ${STAGING_INCDIR}/
-        oe_libinstall -a -so libz ${STAGING_LIBDIR}
-}
-
-DEPENDS = "libtool-native"
diff --git a/meta/packages/zlib/zlib-native_1.2.3.bb b/meta/packages/zlib/zlib-native_1.2.3.bb
deleted file mode 100644 (file)
index 645b2c4..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require zlib_${PV}.bb
-require zlib-native.inc
diff --git a/meta/packages/zlib/zlib-sdk.inc b/meta/packages/zlib/zlib-sdk.inc
deleted file mode 100644 (file)
index 992f0c3..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-ZLIB_EXTRA = ""
-inherit sdk
-
-do_stage() {
-        install -d ${STAGING_INCDIR}
-        install -m 0644 zlib.h ${STAGING_INCDIR}/
-        install -m 0644 zconf.h ${STAGING_INCDIR}/
-        install -m 0644 zlibdefs.h ${STAGING_INCDIR}/
-        oe_libinstall -a -so libz ${STAGING_LIBDIR}
-}
diff --git a/meta/packages/zlib/zlib-sdk_1.2.3.bb b/meta/packages/zlib/zlib-sdk_1.2.3.bb
deleted file mode 100644 (file)
index b6e15c3..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require zlib_${PV}.bb
-require zlib-sdk.inc
index 25677733f849e308df3e70bae27c00a2c785ecdf..ca54b6abfbbe12fcb94eac96ca3897247f1581ea 100644 (file)
@@ -3,31 +3,15 @@ SECTION = "libs"
 PRIORITY = "required"
 HOMEPAGE = "http://www.gzip.org/zlib/"
 LICENSE = "zlib"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "http://www.zlib.net/zlib-1.2.3.tar.bz2 \
                file://1.2.3.3.dfsg.patch.gz;patch=1 \
                file://visibility.patch;patch=1 \
                file://autotools.patch;patch=1 "
 
-S = "${WORKDIR}/zlib-${PV}"
-
 DEPENDS = "libtool-cross"
 
-inherit autotools
-
-do_stage() {
-       install -m 0644 zlib.h ${STAGING_INCDIR}/
-       install -m 0644 zconf.h ${STAGING_INCDIR}/
-       install -m 0644 zlibdefs.h ${STAGING_INCDIR}/
-       oe_libinstall -a -so libz ${STAGING_LIBDIR}
-}
+inherit autotools_stage
 
-do_install() {
-       install -d ${D}${prefix} ${D}${includedir} ${D}${libdir}
-       oe_runmake "prefix=${D}${prefix}" \
-                  "exec_prefix=${D}${exec_prefix}" \
-                  "man3dir=${D}${mandir}/man3" \
-                  "includedir=${D}${includedir}" \
-                  "libdir=${D}${libdir}" install
-}
+BBCLASSEXTEND = "native sdk"