]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-sato-sdk-ptest: Fix free space issues causing test failures
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Apr 2019 17:02:41 +0000 (18:02 +0100)
committerArmin Kuster <akuster808@gmail.com>
Sat, 13 Apr 2019 20:12:40 +0000 (13:12 -0700)
Some tests such as strace-ptest require more than the current 500MB of free
space. Increase the amount available, staying under the 4GB limit. We have more
flexibility now since we shrank kernel-devsrc and the comments are out of date
due to that.

This should improve the strace-ptest results and the util-linux ones since
those sort after strace and also hit the space issues as strace-ptest didn't
clean up after itself when failing.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-sato/images/core-image-sato-sdk-ptest.bb

index 7e3152b4a11203c1b8ad404bd06fc172e358f036..1027ec03be09eec80d83bac38e355cfcb0390f56 100644 (file)
@@ -4,11 +4,12 @@ DESCRIPTION += "Also includes ptest packages."
 
 IMAGE_FEATURES += "ptest-pkgs"
 
-# This image is sufficiently large (~3GB) that it can't actually fit in a live
+# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
 # image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
-# box) and explicitly add just 500MB.
+# box) and explicitly add just 1500MB.
+# strace-ptest in particular needs more than 500MB
 IMAGE_OVERHEAD_FACTOR = "1.0"
-IMAGE_ROOTFS_EXTRA_SPACE = "524288"
+IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
 
 # ptests need more memory than standard to avoid the OOM killer
 QB_MEM = "-m 1024"