]> code.ossystems Code Review - openembedded-core.git/commitdiff
console-tools: move ASNEEDED over-ride into the console-tools recipe
authorAndre McCurdy <armccurdy@gmail.com>
Wed, 9 May 2018 21:46:43 +0000 (14:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 15 May 2018 09:00:30 +0000 (10:00 +0100)
Move the recipe specific over-ride for ASNEEDED into the recipe to
make it more apparent that the over-ride is being applied (and that
it should be re-checked on version updates, etc).

Also misc minor recipe cleanup (re-order variables to follow the OE
style guide, etc).

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/conf/distro/include/as-needed.inc
meta/recipes-core/console-tools/console-tools_0.3.2.bb

index 38de3a10f2b6b946bd59ea3f996f015a107dc45f..91c07627274cd5f1ba9e6658d9ba52cd5c31177a 100644 (file)
@@ -1,7 +1,6 @@
 
 ASNEEDED = "-Wl,--as-needed"
 
-ASNEEDED_pn-console-tools = ""
 ASNEEDED_pn-distcc = ""
 ASNEEDED_pn-openobex = ""
 ASNEEDED_pn-icu = ""
index 286c2a47539ff78325d34cbd14c6c525a96e0e26..6b9c82834cb9f297e15f02c992ae5176e2360c0b 100644 (file)
@@ -1,8 +1,8 @@
+SUMMARY = "Allows you to set-up and manipulate the Linux console"
+DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
 SECTION = "base"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
-SUMMARY = "Allows you to set-up and manipulate the Linux console"
-DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
 PR = "r8"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
@@ -26,8 +26,12 @@ SRC_URI[sha256sum] = "eea6b441672dacd251079fc85ed322e196282e0e66c16303ec64c3a2b1
 UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/lct/files/console-tools-devel/"
 UPSTREAM_CHECK_REGEX = "/console-tools-devel/(?P<pver>(\d\d?\.)+\d\d?)/"
 
+inherit autotools gettext update-alternatives
+
 CFLAGS_append_aarch64 = " -D_USE_TERMIOS "
 
+ASNEEDED = ""
+
 do_configure_prepend () {
        mkdir -p ${S}/m4
        cp ${WORKDIR}/lcmessage.m4 ${S}/m4/
@@ -35,8 +39,6 @@ do_configure_prepend () {
        cp ${WORKDIR}/Makevars ${S}/po/
 }
 
-inherit autotools gettext update-alternatives
-
 ALTERNATIVE_PRIORITY = "30"
 
 bindir_progs = "chvt deallocvt fgconsole openvt"