]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemtap: fix build failure on host system with dyninst installed
authorVictor Kamensky <victor.kamensky@linaro.org>
Thu, 8 Aug 2013 16:14:29 +0000 (09:14 -0700)
committerSaul Wold <sgw@linux.intel.com>
Fri, 9 Aug 2013 15:54:46 +0000 (08:54 -0700)
On host system where dyninst installed (i.e Fedora 18 with SystemTap)
builds fails with the error from do_qa_configure "This autoconf log
indicates errors, it looked at host include and/or library paths
while determining system capabilities." Problematic config.log
indicates inclusion of /usr/include/dyninst/dyntypes.h

Fix for now - disable dyninst in oe builds

Signed-off-by: Victor Kamensky <victor.kamensky@linaro.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/systemtap/systemtap_git.bb

index 9bba5a9752c7a3b86dd9bfa18bb6c6d87a75c2f9..4f60f6b66d9c90f5b728221380cb096365f3dafe 100644 (file)
@@ -13,7 +13,7 @@ RDEPENDS_${PN}_class-nativesdk += "python-native"
 PR = "r1"
 
 EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
-            --without-nss --without-avahi \
+            --without-nss --without-avahi --without-dyninst \
             --disable-server --disable-grapher "
 
 STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"