]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fixes the metacity-clutter revision; packages the plugins; and adds a post
authorRobert Bragg <bob@openedhand.com>
Fri, 26 Sep 2008 15:16:32 +0000 (15:16 +0000)
committerRobert Bragg <bob@openedhand.com>
Fri, 26 Sep 2008 15:16:32 +0000 (15:16 +0000)
install section to use gconftool-2 to enable the "simple" plugin by default.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5299 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gnome/metacity-clutter_git.bb

index d32927147ce700dc340d59bbaa30bb96d04143a4..831ba507ea4cd80c6ff03a2bf5afb090ca66ca43 100644 (file)
@@ -2,8 +2,8 @@ SECTION = "x11/wm"
 DESCRIPTION = "Metacity is the boring window manager for the adult in you."
 LICENSE = "GPL"
 DEPENDS = "startup-notification gtk+ gconf clutter gdk-pixbuf-csource-native"
-PR = "r0"
-PV = "2.25.1+gitr${SRCREV}"
+PR = "r2"
+PV = "2.25.1+git${SRCREV}"
 inherit gnome update-alternatives
 
 SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter"
@@ -18,9 +18,21 @@ EXTRA_OECONF += "--disable-verbose   \
                 --disable-xinerama     \
                 --with-clutter"
 
-FILES_${PN} += "${datadir}/themes"
+FILES_${PN} += "${datadir}/themes ${libdir}/metacity/plugins/clutter/*.so"
+FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
 
 do_stage () {
         autotools_stage_all
 }
 
+pkg_postinst_${PN} () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+    exit 1
+fi
+
+. ${sysconfdir}/init.d/functions
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[simple]'
+}
+