]> code.ossystems Code Review - openembedded-core.git/commitdiff
consolekit: Add glib-2.0 to DEPENDS
authorKhem Raj <raj.khem@gmail.com>
Fri, 1 Jul 2011 17:46:03 +0000 (10:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 1 Jul 2011 22:01:21 +0000 (23:01 +0100)
Otherwise it ends up with this error
| configure: error: Package requirements (dbus-glib-1 >= 0.82
|   gobject-2.0 >= 2.14
|   gthread-2.0 >= 2.14
| ) were not met:
|
| No package 'gobject-2.0' found
| No package 'gthread-2.0' found
|
| Consider adjusting the PKG_CONFIG_PATH environment variable if you
| installed software in a non-standard prefix.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/consolekit/consolekit_0.4.5.bb

index c934d0f838e30fd8c77b0086fec8a2cc5f6e5865..661cca65ec7971786f0d175560d00f64ef89e736 100644 (file)
@@ -2,13 +2,13 @@ DESCRIPTION = "ConsoleKit is a framework for defining and tracking users, login
 HOMEPAGE="http://www.freedesktop.org/wiki/Software/ConsoleKit"
 BUGTRACKER="https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit"
 
-PR = "r3"
+PR = "r4"
 
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
                     file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3"
 
-DEPENDS = "dbus polkit ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+DEPENDS = "glib-2.0 dbus polkit ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
 inherit gnome