]> code.ossystems Code Review - openembedded-core.git/commitdiff
sed: Upgraded to the latest version 4.2.1
authorDongxiao Xu <dongxiao.xu@intel.com>
Wed, 1 Sep 2010 03:18:15 +0000 (11:18 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Sep 2010 08:50:50 +0000 (09:50 +0100)
sed version 4.2.1 is under GPLv3 license
inherit update-altenatives to handle the install priority issue

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-extended/sed/sed_4.2.1.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/sed/sed_4.2.1.bb b/meta/recipes-extended/sed/sed_4.2.1.bb
new file mode 100644 (file)
index 0000000..5147b0d
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "sed is a Stream EDitor."
+HOMEPAGE = "http://www.gnu.org/software/sed/"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
+                    file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
+SECTION = "console/utils"
+PR = "r0"
+
+DEPENDS = "gettext"
+
+SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+do_install () {
+       autotools_do_install
+       install -d ${D}${base_bindir}
+       mv ${D}${bindir}/sed ${D}${base_bindir}/sed.${PN}
+}
+
+ALTERNATIVE_NAME = "sed"
+ALTERNATIVE_PATH = "sed.${PN}"
+ALTERNATIVE_PRIORITY = "100"
+
+BBCLASSEXTEND = "native"