]> code.ossystems Code Review - openembedded-core.git/commitdiff
*: use print() as a function
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 18 Jun 2010 10:50:15 +0000 (12:50 +0200)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 16 Jul 2010 14:10:40 +0000 (15:10 +0100)
to make python3 happy

(Bitbake rev: c82926ccdd4ec4e3ad6e78a381dacb96adf9b409)

Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake
bitbake/doc/manual/usermanual.xml
bitbake/lib/bb/msg.py

index fdf1e20f84167a3e754039d8cac89a455a025468..7caa5d95e6efe7b3b325a7047081a9a7151bfb35 100755 (executable)
@@ -195,13 +195,13 @@ Default BBFILES are the .bb files in the current directory.""")
         uimodule = __import__("bb.ui", fromlist = [ui])
         ui_init = getattr(uimodule, ui).init
     except AttributeError:
-        print "FATAL: Invalid user interface '%s' specified. " % ui
-        print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
+        print("FATAL: Invalid user interface '%s' specified. " % ui)
+        print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
     else:
         try:
             return_value = ui_init(serverConnection.connection, serverConnection.events)
         except Exception as e:
-            print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
+            print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
             raise
     finally:
         serverConnection.terminate()
index 7b87ad837f8a2a99ad22d4bf362fd317d3009870..748ac319ef94db971cb71c2ef7fce80040d8e610 100644 (file)
@@ -218,8 +218,8 @@ python myclass_eventhandler() {
     from bb.event import getName
     from bb import data
 
-    print "The name of the Event is %s" % getName(e)
-    print "The file we run for is %s" % data.getVar('FILE', e.data, True)
+    print("The name of the Event is %s" % getName(e))
+    print("The file we run for is %s" % data.getVar('FILE', e.data, True))
 }
 </screen></para><para>
 This event handler gets called every time an event is triggered. A global variable <varname>e</varname> is defined. <varname>e</varname>.data contains an instance of bb.data. With the getName(<varname>e</varname>)
index cea5efb5a401c4d821101273f0bbd0508ee21063..8d2bcce45299c3ff91acd398948213596d987ef6 100644 (file)
@@ -110,7 +110,7 @@ def debug(level, msgdomain, msg, fn = None):
     if debug_level[msgdomain] >= level:
         bb.event.fire(MsgDebug(msg), None)
         if not bb.event._ui_handlers:
-            print('DEBUG: ' + msg)
+            print('DEBUG: %s' % (msg))
 
 def note(level, msgdomain, msg, fn = None):
     if not msgdomain:
@@ -119,20 +119,20 @@ def note(level, msgdomain, msg, fn = None):
     if level == 1 or verbose or debug_level[msgdomain] >= 1:
         bb.event.fire(MsgNote(msg), None)
         if not bb.event._ui_handlers:
-            print('NOTE: ' + msg)
+            print('NOTE: %s' % (msg))
 
 def warn(msgdomain, msg, fn = None):
     bb.event.fire(MsgWarn(msg), None)
     if not bb.event._ui_handlers:
-        print('WARNING: ' + msg)
+        print('WARNING: %s' % (msg))
 
 def error(msgdomain, msg, fn = None):
     bb.event.fire(MsgError(msg), None)
-    print 'ERROR: ' + msg
+    print('ERROR: %s' % (msg))
 
 def fatal(msgdomain, msg, fn = None):
     bb.event.fire(MsgFatal(msg), None)
-    print('FATAL: ' + msg)
+    print('FATAL: %s' % (msg))
     sys.exit(1)
 
 def plain(msg, fn = None):