]> code.ossystems Code Review - openembedded-core.git/commitdiff
liberation-fonts: postinst can't be called offline
authorIlya Yanok <yanok@emcraft.com>
Wed, 27 Apr 2011 22:56:59 +0000 (00:56 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 23:48:10 +0000 (00:48 +0100)
fc-cache should be called on target system. Or maybe we should pass a
suitable directory list to it?

Signed-off-by: Ilya Yanok <yanok@emcraft.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.04.bb
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb

index c50d6eb3ffa6183bdf2fa012b9a324d0ad30c9bd..81aee0ed0b700034474629a038f9aeb840921b58 100644 (file)
@@ -34,6 +34,9 @@ do_install () {
 
 pkg_postinst_${PN} () {
 #!/bin/sh
+if [ "x$D" != "x" ] ; then
+       exit 1
+fi
 fc-cache
 }
 
index d910cff2bb96ab137f7c8dc098b5e88bb13e5d1a..1f023b760b70b0f9ded3ca5925eae9b337fa2e80 100644 (file)
@@ -35,6 +35,9 @@ do_install () {
 
 pkg_postinst_${PN} () {
 #!/bin/sh
+if [ "x$D" != "x" ] ; then
+       exit 1
+fi
 fc-cache
 }