]> code.ossystems Code Review - openembedded-core.git/commitdiff
added recipe for metacity-clutter
authorTomas Frydrych <tf@openedhand.com>
Wed, 24 Sep 2008 08:56:27 +0000 (08:56 +0000)
committerTomas Frydrych <tf@openedhand.com>
Wed, 24 Sep 2008 08:56:27 +0000 (08:56 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5252 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/conf/distro/include/poky-fixed-revisions.inc
meta/conf/distro/include/poky-floating-revisions.inc
meta/packages/gnome/metacity-clutter_git.bb [new file with mode: 0644]

index c6c391683967ea6601b44b76ead51269d8fda55c..22410dc06c9322373b3fcc09e43e64138c463c93 100644 (file)
@@ -142,6 +142,7 @@ SRCREV_pn-usbpath = "3172"
 SRCREV_pn-xserver-kdrive-glamo ?= "a51364e2f23d4b6331c5ed613ce3f7e15f8e540f"
 SRCREV_pn-gsm0710muxd ?= "6fecc78198dd821bbe29efd096bd8fecd855179d"
 SRCREV_pn-gsmd2 ?= "963f34df8fa3ff4b301079dcf86e9acea6b6fe0f"
+SRCREV_pn-metacity-clutter ?= "94d4e3d3f0407085f4453ed4208cdca3c093c692"
 
 #
 # Preferred Versions:
index cbf9c04baf72488db88ac68c2ba1b0526be7ecf4..ea7f9e0d47956aa685522cff727f14da4894ed20 100644 (file)
@@ -56,6 +56,7 @@ SRCREV_pn-table ?= "${AUTOREV}"
 SRCREV_pn-libmatchbox ?= "${AUTOREV}"
 SRCREV_pn-tasks ?= "${AUTOREV}"
 SRCREV_pn-libjana = "${AUTOREV}"
+SRCREV_pn-metacity-clutter = "${AUTOREV}"
 
 SRCDATE_oprofile ?= "${DATE}"
 
diff --git a/meta/packages/gnome/metacity-clutter_git.bb b/meta/packages/gnome/metacity-clutter_git.bb
new file mode 100644 (file)
index 0000000..5c9b1dd
--- /dev/null
@@ -0,0 +1,26 @@
+SECTION = "x11/wm"
+DESCRIPTION = "Metacity is the boring window manager for the adult in you."
+LICENSE = "GPL"
+DEPENDS = "startup-notification gtk+ gconf clutter"
+PR = "r0"
+PV = "2.25.1+gitr${SRCREV}"
+inherit gnome update-alternatives
+
+SRC_URI = "git://git.o-hand.com/metacity-clutter.git;protocol=git;branch=clutter"
+S = "${WORKDIR}/git"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/metacity"
+ALTERNATIVE_PRIORITY = "11"
+
+EXTRA_OECONF += "--disable-verbose     \
+                --disable-xinerama     \
+                --with-clutter"
+
+FILES_${PN} += "${datadir}/themes"
+
+do_stage () {
+        autotools_stage_all
+}
+