]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: set PYTHONHOME for nativesdk
authorChristopher Larson <chris_larson@mentor.com>
Fri, 5 Feb 2016 17:02:34 +0000 (10:02 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 7 Feb 2016 17:29:45 +0000 (17:29 +0000)
This ensures that the nativesdk python functions correctly without needing to
set PYTHONHOME in the sdk environment setup script.

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python_2.7.11.bb

index 0287c191ab307bac6a0a64706e8980ea646db2bb..0c00d6e4e40f23f11ea4ad1c2c39710b52b80cba 100644 (file)
@@ -123,7 +123,7 @@ do_install() {
 }
 
 do_install_append_class-nativesdk () {
-       create_wrapper ${D}${bindir}/python2.7 TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
+       create_wrapper ${D}${bindir}/python2.7 PYTHONHOME='${prefix}' TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo'
 }
 
 SSTATE_SCAN_FILES += "Makefile"