]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcalctool: Fix compile issues, disable docs, update to 5.8.17
authorRichard Purdie <richard@openedhand.com>
Wed, 16 May 2007 15:01:41 +0000 (15:01 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 16 May 2007 15:01:41 +0000 (15:01 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1736 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gcalctool/gcalctool/fix-includedir.patch
meta/packages/gcalctool/gcalctool/makefile-fix.diff [deleted file]
meta/packages/gcalctool/gcalctool_5.8.17.bb [new file with mode: 0644]

index 62b386bf9d99f5c0d04894fd8182c1e133ca3cfb..aeb02ab2c1f96ff7cd6c2a3b7bbf62187e86a08d 100644 (file)
@@ -1,12 +1,31 @@
-Index: gcalctool-5.7.32/gcalctool/Makefile.am
+---
+ Makefile.am           |    2 +-
+ gcalctool/Makefile.am |    2 --
+ 2 files changed, 1 insertion(+), 3 deletions(-)
+
+Index: gcalctool-5.8.17/gcalctool/Makefile.am
 ===================================================================
---- gcalctool-5.7.32.orig/gcalctool/Makefile.am        2007-04-07 19:44:00.000000000 +0200
-+++ gcalctool-5.7.32/gcalctool/Makefile.am     2007-04-07 19:44:15.000000000 +0200
-@@ -1,7 +1,6 @@
+--- gcalctool-5.8.17.orig/gcalctool/Makefile.am        2005-12-19 15:46:57.000000000 +0000
++++ gcalctool-5.8.17/gcalctool/Makefile.am     2007-05-16 16:03:26.000000000 +0100
+@@ -1,8 +1,6 @@
  ## Process this file with automake to produce Makefile.in
  
  INCLUDES = \
 -      -I$(includedir) \
-       -DG_DISABLE_DEPRECATED \
+-      -DG_DISABLE_DEPRECATED \
        -DGDK_PIXBUF_DISABLE_DEPRECATED \
        -DGDK_DISABLE_DEPRECATED \
+       -DGNOME_DISABLE_DEPRECATED \
+Index: gcalctool-5.8.17/Makefile.am
+===================================================================
+--- gcalctool-5.8.17.orig/Makefile.am  2007-05-16 15:35:44.000000000 +0100
++++ gcalctool-5.8.17/Makefile.am       2007-05-16 16:06:46.000000000 +0100
+@@ -29,7 +29,7 @@ DISTCLEANFILES =                \
+       gnome-doc-utils.make    \
+       gcalctool.desktop
+-SUBDIRS = po gcalctool help
++SUBDIRS = po gcalctool
+ SCHEMAS_FILE = gcalctool.schemas
diff --git a/meta/packages/gcalctool/gcalctool/makefile-fix.diff b/meta/packages/gcalctool/gcalctool/makefile-fix.diff
deleted file mode 100644 (file)
index 48a5462..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- gcalctool/Makefile.am~     2005-03-23 16:50:10.000000000 +0000
-+++ gcalctool/Makefile.am      2006-03-20 13:59:17.000000000 +0000
-@@ -30,15 +30,8 @@
- SCHEMAS_FILE = gcalctool.schemas
--### Install the schemas file in /etc if GNOME support is not compiled in,
--### and do not install the schemas at all
--if DISABLE_GNOME
--schemasdir = $(sysconfdir)/gcalctool
--schemas_DATA = $(SCHEMAS_FILE)
--else
- schemadir = $(GCONF_SCHEMA_FILE_DIR)
- schema_DATA = $(SCHEMAS_FILE)
--endif
- EXTRA_DIST = \
-       autogen.sh \
diff --git a/meta/packages/gcalctool/gcalctool_5.8.17.bb b/meta/packages/gcalctool/gcalctool_5.8.17.bb
new file mode 100644 (file)
index 0000000..c72860c
--- /dev/null
@@ -0,0 +1,12 @@
+LICENSE = "GPL"
+SECTION = "x11"
+DEPENDS = "gtk+ gnome-doc-utils"
+DESCRIPTION = "gcalctool is a powerful calculator"
+PR = "r0"
+
+SRC_URI = "http://download.gnome.org/sources/${PN}/5.8/${PN}-${PV}.tar.gz \
+       file://fix-includedir.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gnome"