]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: Update changing .ipk avoidence patch
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 27 Aug 2009 15:12:57 +0000 (16:12 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 27 Aug 2009 15:12:57 +0000 (16:12 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/opkg-utils/opkg-utils/index-ignore-filenotfound.patch
meta/packages/opkg-utils/opkg-utils_svn.bb

index bafc2f6a1ca5824ac27104bf42d59f6a04c36ea1..e4a548156f2a46c9c13a5fb60c52176c93fd01a7 100644 (file)
@@ -1,7 +1,14 @@
+If we're building an image and some package rebuilds while this is happening
+some package can be removed/added to the ipk deploy directory. The image will
+not depend on this package so we can safely ignore these cases rather than 
+error out.
+
+RP - 26/8/09
+
 Index: opkg-utils/opkg-make-index
 ===================================================================
 --- opkg-utils.orig/opkg-make-index    2009-08-26 17:21:26.000000000 +0100
-+++ opkg-utils/opkg-make-index 2009-08-26 20:49:52.000000000 +0100
++++ opkg-utils/opkg-make-index 2009-08-27 16:11:22.000000000 +0100
 @@ -96,6 +96,7 @@
  files=glob(pkg_dir + '/*.ipk') + glob(pkg_dir + '/*.deb')
  files.sort()
@@ -10,17 +17,20 @@ Index: opkg-utils/opkg-make-index
       basename = os.path.basename(filename)
       pkg = None
       fnameStat = os.stat(filename)
-@@ -130,6 +131,9 @@
+@@ -130,6 +131,12 @@
                 to_morgue(basename)
            if opt_s:
                 print filename
 +  except OSError:
 +      sys.stderr.write("Package %s disappeared on us!\n" % (filename))
++      continue
++  except IOError:
++      sys.stderr.write("Package %s disappeared on us!\n" % (filename))
 +      continue
  
  pkgsStampsFile = open(stamplist_filename, "w")
  for f in pkgsStamps.keys():
-@@ -148,6 +152,7 @@
+@@ -148,6 +155,7 @@
  names = packages.packages.keys()
  names.sort()
  for name in names:
@@ -28,13 +38,17 @@ Index: opkg-utils/opkg-make-index
       pkg = packages.packages[name]
       if locales_dir and pkg.depends:
           depends = string.split(pkg.depends, ',')
-@@ -165,6 +170,9 @@
+@@ -165,6 +173,13 @@
       if (verbose):
            sys.stderr.write("Writing info for package %s\n" % (pkg.package,))
       print pkg
 +  except OSError:
 +      sys.stderr.write("Package %s disappeared on us!\n" % (name))
 +      continue
++  except IOError:
++      sys.stderr.write("Package %s disappeared on us!\n" % (name))
++      continue
++
  if packages_filename:
       sys.stdout.close()
       sys.stdout = old_stdout
index a141505710fc403659ab2cdd8cc17e34249c5212..b06ea6a68ed0f34493b387203892aa65f288618b 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "optional"
 LICENSE = "GPL"
 RDEPENDS = "python"
 RDEPENDS_virtclass-native = ""
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
            file://index-ignore-filenotfound.patch;patch=1"