]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot-mkimage-native: Convert to use do_install for staging
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 21:49:29 +0000 (21:49 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 21:49:29 +0000 (21:49 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb

index 38dd700d081e20a06df37d11809f5fc306fdb6d6..6922d69e070b32d064ff26893a582322ce387d7b 100644 (file)
@@ -12,11 +12,13 @@ inherit native
 EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
 
 do_compile () {
-       oe_runmake smdk2410_config
-        oe_runmake tools
+       oe_runmake smdk2410_config
+       oe_runmake tools
 }
 
-do_stage () {
-        install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
-        ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+NATIVE_INSTALL_WORKS = "1"
+do_install () {
+       install -d ${D}${bindir}/
+       install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+       ln -sf uboot-mkimage ${D}${bindir}/mkimage
 }