]> code.ossystems Code Review - openembedded-core.git/commitdiff
ffmpeg: add PACKAGECONFIG support for fdk-aac
authorScott Branden <scott.branden@broadcom.com>
Tue, 25 Feb 2020 00:11:15 +0000 (16:11 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 28 Feb 2020 23:08:11 +0000 (23:08 +0000)
Add PACKAGECONFIG support for fdk-aac in ffmpeg.

Signed-off-by: Scott Branden <scott.branden@broadcom.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/ffmpeg/ffmpeg_4.2.2.bb

index 20a8249b0227899c5e09c057bc97930862253ae0..d7b06410547460af169c69608a667f1c9d3e0946 100644 (file)
@@ -59,6 +59,7 @@ PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
 # features to support
 PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
 PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
+PACKAGECONFIG[fdk-aac] = "--enable-libfdk-aac --enable-nonfree,--disable-libfdk-aac,fdk-aac"
 PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
 PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm"
 PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack"