]> code.ossystems Code Review - openembedded-core.git/commitdiff
python 2.7: fix multilib patch to accept multiarch style paths
authorKoen Kooi <koen@dominion.thruhere.net>
Mon, 16 Apr 2018 13:00:21 +0000 (15:00 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 May 2018 08:54:57 +0000 (09:54 +0100)
Using 'basename' to strip the prefix fails when using multiarch style paths.

Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python/multilib.patch

index 979b601bf1b22e5283b924b84dff8b7777d7cf5f..84bcb6aa8a6db27a8f9bc7f16fa4b2fde46baf91 100644 (file)
@@ -33,6 +33,12 @@ EXTRA_OECONF = "\
   ${PYTHONLSBOPTS} \
 "
 
+do_configure_prepend() {
+       libdirleaf="$(echo ${libdir} | sed -e 's:${prefix}/::')"
+       sed -i -e "s:SEDMELIBLEAF:${libdirleaf}:g" \
+               ${S}/configure.ac
+}
+
 do_install_append () {
        sed -i -e 's:${HOSTTOOLS_DIR}/install:install:g' \
                -e 's:${HOSTTOOLS_DIR}/mkdir:mkdir:g' \
index 1116dd518e49cf3163189b30141be65513d6e888..d24bc15f013e5b2b8c59c9b43f55008d85da7e7b 100644 (file)
@@ -11,7 +11,7 @@ Index: Python-2.7.14/configure.ac
  
 +AC_SUBST(LIB)
 +AC_MSG_CHECKING(LIB)
-+LIB=`basename ${libdir}`
++LIB="SEDMELIBLEAF"
 +AC_MSG_RESULT($LIB)
  
  AC_SUBST(LIBRARY)