]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf.bb: fix multilib build
authorRobert Yang <liezhi.yang@windriver.com>
Tue, 12 Aug 2014 11:10:19 +0000 (04:10 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 2 Sep 2014 16:51:45 +0000 (17:51 +0100)
Fixed:
$ bitbake perf lib32-perf
ERROR: QA Issue: lib32-perf: Files/directories were installed but not shipped
  /usr/lib64
  /usr/lib64/traceevent
  /usr/lib64/traceevent/plugins
  /usr/lib64/traceevent/plugins/plugin_function.so
  /usr/lib64/traceevent/plugins/plugin_scsi.so
  /usr/lib64/traceevent/plugins/plugin_hrtimer.so
  /usr/lib64/traceevent/plugins/plugin_kmem.so
  /usr/lib64/traceevent/plugins/plugin_jbd2.so
  /usr/lib64/traceevent/plugins/plugin_xen.so
  /usr/lib64/traceevent/plugins/plugin_mac80211.so
  /usr/lib64/traceevent/plugins/plugin_cfg80211.so
  /usr/lib64/traceevent/plugins/plugin_sched_switch.so
  /usr/lib64/traceevent/plugins/plugin_kvm.so [installed-vs-shipped]

The perf.do_configure edits kernel's
${STAGING_KERNEL_DIR}/tools/perf/config/Makefile, there would be
problems since kernel doesn't have multilib, and the build result is
undetermined.

Previously, the sed command changed libdir to /usr/lib64 (or 32) in the
Makefile, so the build result was different if we build perf (64) first
or lib32-perf first.

Use the weak assignment "libdir ?=" to instead of "libdir =" will fix
the problem since the multilib builds are in different processes, and
they won't affect each other any more.

The sed command will match both $(prefix)/$(lib) and $(prefix)/lib since
the Makefile may has been modified before this patch.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index bfd210cf2ecb6aa3c0a12e72fdb649ed82362788..ebfedb91d715ee923cbf373ad6a3fc87d2c2db86 100644 (file)
@@ -121,10 +121,12 @@ do_configure_prepend () {
     # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
     # build, with a 64 bit multilib, the arch won't match and the detection of a 
     # 64 bit build (and library) are not exected. To ensure that libraries are
-    # installed to the correct location, we can make the substitution in the 
-    # config/Makefile. For non multilib builds, this has no impact.
+    # installed to the correct location, we can use the weak assignment in the
+    # config/Makefile.
     if [ -e "${S}/tools/perf/config/Makefile" ]; then
-        sed -i 's,libdir = $(prefix)/$(lib),libdir = $(prefix)/${baselib},' ${S}/tools/perf/config/Makefile
+        # Match $(prefix)/$(lib) and $(prefix)/lib
+        sed -i 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
+            ${S}/tools/perf/config/Makefile
     fi
     # We need to ensure the --sysroot option in CC is preserved
     if [ -e "${S}/tools/perf/Makefile.perf" ]; then