]> code.ossystems Code Review - openembedded-core.git/commitdiff
ppp: Add extra include dirs
authorKhem Raj <raj.khem@gmail.com>
Sat, 11 Apr 2015 01:20:35 +0000 (18:20 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 13 Apr 2015 21:28:35 +0000 (22:28 +0100)
Just run configure, the configure script is not really
a autoconf generated script so just run it

Include path is needed to be there since
the headers from it are used during build in subcomponents

Change-Id: Ib1f24fd18bc8564e3c74ab834b7cf0fdf955d0e1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/ppp/ppp_2.4.7.bb

index 92ca0c92c63dcb22a2db2add9b0522e798e18e97..4219d45591db34503c241ac9d26210352a4cc8da 100644 (file)
@@ -43,7 +43,11 @@ EXTRA_OECONF = "--disable-strip"
 # Package Makefile computes CFLAGS, referencing COPTS.
 # Typically hard-coded to '-O2 -g' in the Makefile's.
 #
-EXTRA_OEMAKE += ' COPTS="${CFLAGS}"'
+EXTRA_OEMAKE += ' COPTS="${CFLAGS} -I${S}/include"'
+
+do_configure () {
+       oe_runconf
+}
 
 do_install_append () {
        make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp