]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: avoid failing if no udev rules provided
authorPeter Bergin <peter@berginkonsult.se>
Tue, 15 Sep 2020 19:33:05 +0000 (21:33 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Sep 2020 13:01:51 +0000 (14:01 +0100)
In the case when no udev rules are provided by the recipe the do_install
step of systemd is failing with:

    install: cannot stat '<WORKDIR>/*.rules': No such file or directory

By default the systemd recipe provides touchscreen.rules but in the
case this is unwanted on target the install step fails. This solution
is dynamic and search for *.rules files in $WORKDIR. If found they are
installed.

Signed-off-by: Peter Bergin <peter@berginkonsult.se>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_246.2.bb

index 238cd4741fc8e02f4e6dd0aeaad664a0b5b0e4eb..af10e4212bb964bbafa466712b8be6ebe522449c 100644 (file)
@@ -232,7 +232,9 @@ do_install() {
 
        install -d ${D}${sysconfdir}/udev/rules.d/
        install -d ${D}${sysconfdir}/tmpfiles.d
-       install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
+       for rule in $(find ${WORKDIR} -maxdepth 1 -type f -name "*.rules"); do
+               install -m 0644 $rule ${D}${sysconfdir}/udev/rules.d/
+       done
 
        install -m 0644 ${WORKDIR}/00-create-volatile.conf ${D}${sysconfdir}/tmpfiles.d/