]> code.ossystems Code Review - openembedded-core.git/commitdiff
Various misc metadata fixes to enable poky builds again
authorRichard Purdie <richard@openedhand.com>
Mon, 13 Feb 2006 00:21:13 +0000 (00:21 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 13 Feb 2006 00:21:13 +0000 (00:21 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@273 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/classes/package.bbclass
openembedded/conf/distro/poky.conf
openembedded/packages/eds/eds-dbus_svn.bb
openembedded/packages/fontconfig/fontconfig_2.2.95.bb
openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
openembedded/packages/gtk+/gtk+_2.6.7.bb

index fd8d1b7b099f5d5587e65646cfe8923ef7916f4d..03a533d59a812c6bd3f2c55bfd9df1d3745e5bef 100644 (file)
@@ -84,8 +84,8 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst
 # Function to strip a single file, called from RUNSTRIP below
 # A working 'file' (one which works on the target architecture)
 # is necessary for this stuff to work.
-PACKAGE_DEPENDS ?= "file-native"
-DEPENDS_prepend =+ "${PACKAGE_DEPENDS} "
+#PACKAGE_DEPENDS ?= "file-native"
+#DEPENDS_prepend =+ "${PACKAGE_DEPENDS} "
 #FIXME: this should be "" when any errors are gone!
 IGNORE_STRIP_ERRORS ?= "1"
 
index ad35c65b00a2b668dff47df30e2ba11c3bc430c6..a996183c79a39aca12eb19d790c71c01f08fcdfc 100644 (file)
@@ -69,6 +69,8 @@ PREFERRED_PROVIDER_x11 = "diet-x11"
 PREFERRED_PROVIDER_gconf=gconf-dbus
 PREFERRED_PROVIDER_gnome-vfs=gnome-vfs-dbus
 
+PREFERRED_VERSION_gnome-vfs-dbus = "2.12.0+cvs${SRCDATE}"
+
 
 #
 # CVS Dates to use:
@@ -170,3 +172,5 @@ PREFERRED_VERSION_xrdb ?= "0.0+cvs${SRCDATE}"
 PREFERRED_VERSION_xst ?= "0.15"
 
 PREFERRED_VERSION_oprofile ?= "0.0+cvs${SRCDATE}"
+
+PCMCIA_MANAGER = "pcmciautils"
\ No newline at end of file
index 98658a1fae11b67798999eb58a34460fd04b6f58..a402e65a277a13c57009304e52c2fa4d79a71b44 100755 (executable)
@@ -1,6 +1,7 @@
 LICENSE = "LGPL"
 DEPENDS = "glib-2.0 gtk+ gconf dbus db gnome-common libglade libiconv"
-RDEPENDS = "gconf dbus-1 db libiconv"
+RDEPENDS = "gconf db libiconv"
+#dbus
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Evolution database backend server"
 PV = "1.4.0+svn${SRCDATE}"
index 6989b7a053ff720db5cc8cb45beba815791a775f..78b35b179328e0d0e3165a867581cb1070138464 100644 (file)
@@ -7,11 +7,13 @@ SRC_URI = "http://pdx.freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz
            file://fc-glyphname.patch;patch=1 \
            file://fc-lang.patch;patch=1 \
           file://local.conf"
-PR = "r1"
+PR = "r2"
 
 PACKAGES =+ "fontconfig-utils "
 FILES_fontconfig-utils = "${bindir}/*"
 
+PKG_fontconfig-utils=fontconfig-utils
+
 S = "${WORKDIR}/fontconfig-${PV}"
 
 inherit autotools pkgconfig
index 660271d1c020d9e4a2df3d1a2292335971899bcf..4a890ac32ceaa8454fdc7719183dfaab8a305227 100755 (executable)
@@ -89,6 +89,8 @@ do_stage() {
        for i in ${GNOME_VFS_PLATFORM_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/include/libgnomevfs/; done
 }
 
+PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
+
 python populate_packages_prepend () {
         print bb.data.getVar('FILES_gnome-vfs', d, 1)
 
index bcfd2b598d5b0f9df0dfae0840769ebdd99ac615..e4e93cacddfd3fa423e1b77dc7606b01b98310ff 100644 (file)
@@ -64,7 +64,7 @@ fi
 
 }
 
-PACKAGES_DYANMIC = "gdk-pixbuf-loader-* gtk-immodule-*"
+PACKAGES_DYNAMIC = "gdk-pixbuf-loader-* gtk-immodule-*"
 
 python populate_packages_prepend () {
        import os.path