]> code.ossystems Code Review - openembedded-core.git/commitdiff
gtk+3: disable Xinerama support
authorRoss Burton <ross.burton@intel.com>
Thu, 16 May 2013 17:05:30 +0000 (18:05 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 17 May 2013 06:35:43 +0000 (09:35 +0300)
GTK+ has enabled by default support for Xinerama, but it's not a build
dependency so this can be enabled or disabled depending if xinerama has been
built previously.

This can cause problems with sstate, and result in situations where
PKG_CHECK_MODULES() for GTK+ can appear successful but the CFLAGS are not set.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-gnome/gtk+/gtk+3_3.4.4.bb

index e2a7ef7da0903b90c9e56b8b3e0ef48d46f55656..16e3f1fc2a8d8ca7b340b00d45e2ce03c3e01566 100644 (file)
@@ -39,6 +39,7 @@ do_configure_prepend() {
 EXTRA_OECONF += " \
                  --disable-gtk2-dependency \
                  --disable-glibtest \
+                 --disable-xinerama \
                  --enable-modules \
                  --disable-cups \
 "