]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkit-gtk: disable JIT for armv5/armv6
authorCristian Iorga <cristian.iorga@intel.com>
Mon, 23 Mar 2015 18:31:38 +0000 (20:31 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 24 Mar 2015 10:07:19 +0000 (10:07 +0000)
JIT for JS causes webkit to crash for
ARM v5 and ARM v6 arch, so disable it for now.

TODO: re-evaluate after webkit-gtk upgrade.

Fixes [YOCTO #6931].

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/webkit/webkit-gtk_1.8.3.bb

index 920e1a0a766d09ea3c6f7e28976c9002879b42b3..15c73cfca8e910f48889a38cb76cc8772a3d64dc 100644 (file)
@@ -50,6 +50,8 @@ EXTRA_OECONF = "\
                 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '--enable-webgl', '--disable-webgl', d)} \
                 UNICODE_CFLAGS=-D_REENTRANT \
                "
+EXTRA_OECONF_append_armv5 = " --disable-jit"
+EXTRA_OECONF_append_armv6 = " --disable-jit"
 
 #default unicode backend icu breaks in cross-compile when target and host are different endian type
 EXTRA_OECONF_append_powerpc = " --with-unicode-backend=glib"