]> code.ossystems Code Review - openembedded-core.git/commitdiff
jpeg: added native version
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 24 Sep 2008 14:20:08 +0000 (14:20 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 24 Sep 2008 14:20:08 +0000 (14:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5259 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/jpeg/jpeg-native_6b.bb [new file with mode: 0644]

diff --git a/meta/packages/jpeg/jpeg-native_6b.bb b/meta/packages/jpeg/jpeg-native_6b.bb
new file mode 100644 (file)
index 0000000..450e4b3
--- /dev/null
@@ -0,0 +1,14 @@
+SECTION = "libs"
+require jpeg_${PV}.bb
+inherit native
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/jpeg-${PV}"
+DEPENDS = ""
+
+do_stage() {
+        install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
+        install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
+        install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
+        install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
+        install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
+        oe_libinstall -so libjpeg ${STAGING_LIBDIR}
+}