]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: move SRC_URI out of gmp.inc + minor reformatting
authorAndre McCurdy <armccurdy@gmail.com>
Fri, 5 Feb 2016 19:56:16 +0000 (11:56 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 7 Feb 2016 17:29:45 +0000 (17:29 +0000)
The base SRC_URI in gmp.inc was wrong for gmp 4.2.1 and was not being
used by gmp 6.1.0. Remove it and make each recipe responsible for
defining its own SRC_URI.

Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-support/gmp/gmp.inc
meta/recipes-support/gmp/gmp_4.2.1.bb
meta/recipes-support/gmp/gmp_6.1.0.bb

index 6752a39d13422bdd19d24c286ad522f840b7d19e..1e3e2a0b43828c235e574aee8db374000e0afea3 100644 (file)
@@ -1,16 +1,13 @@
-SECTION = "devel"
 SUMMARY = "GNU multiprecision arithmetic library"
 DESCRIPTION = "GMP is a free library for arbitrary precision arithmetic, operating on signed integers, rational numbers, and floating point numbers"
 HOMEPAGE = "http://gmplib.org/"
-
-REVISION ?= ""
-SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2"
+SECTION = "devel"
 
 inherit autotools texinfo
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
+
 ARM_INSTRUCTION_SET = "arm"
 
 BBCLASSEXTEND = "native nativesdk"
-
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[readline] = "--with-readline=yes,--with-readline=no,readline"
index bfc6a380e68d767f9ff27543c826882511b13f6a..c25e5ea6ba046b7ecc9238b54eff037eee7d417e 100644 (file)
@@ -7,9 +7,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a \
                     file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24 \
                     file://gmp-h.in;beginline=6;endline=21;md5=e056f74a12c3277d730dbcfb85d2ca34"
 
-SRC_URI += "file://Use-__gnu_inline__-attribute.patch \
-            file://gmp_fix_for_automake-1.12.patch \
-            "
+SRC_URI = "https://gmplib.org/download/${BPN}/archive/${BP}.tar.bz2 \
+           file://Use-__gnu_inline__-attribute.patch \
+           file://gmp_fix_for_automake-1.12.patch \
+"
 
 SRC_URI[md5sum] = "091c56e0e1cca6b09b17b69d47ef18e3"
 SRC_URI[sha256sum] = "d07ffcb37eecec35c5ec72516d10b35fdf6e6fef1fcf1dcd37e30b8cbf8bf941"
index b26b4d510ac5270e719a1336105941897cacbac0..44bd8a229cce0a1fc99d2a3e1eba667c5967f60e 100644 (file)
@@ -1,17 +1,19 @@
 require gmp.inc
 
-LICENSE="GPLv2+ | LGPLv3+"
+LICENSE = "GPLv2+ | LGPLv3+"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                    file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
                    file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
 "
 
+REVISION = ""
 SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \
            file://amd64.patch \
            file://use-includedir.patch \
            file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \
            "
+
 SRC_URI[md5sum] = "86ee6e54ebfc4a90b643a65e402c4048"
 SRC_URI[sha256sum] = "498449a994efeba527885c10405993427995d3f86b8768d8cdf8d9dd7c6b73e8"
 
@@ -27,4 +29,3 @@ do_install_append_class-target() {
 }
 
 SSTATE_SCAN_FILES += "gmp.h"
-