]> code.ossystems Code Review - openembedded-core.git/commitdiff
glibc-initial: Factor code into common .inc file
authorRichard Purdie <richard@openedhand.com>
Sun, 21 Oct 2007 19:12:24 +0000 (19:12 +0000)
committerRichard Purdie <richard@openedhand.com>
Sun, 21 Oct 2007 19:12:24 +0000 (19:12 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2941 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/glibc/glibc-initial.inc [new file with mode: 0644]
meta/packages/glibc/glibc-initial_2.4.bb
meta/packages/glibc/glibc-initial_2.5.bb
meta/packages/glibc/glibc-initial_csl-2005q3-2.bb

diff --git a/meta/packages/glibc/glibc-initial.inc b/meta/packages/glibc/glibc-initial.inc
new file mode 100644 (file)
index 0000000..9355320
--- /dev/null
@@ -0,0 +1,45 @@
+SECTION = "libs"
+DEPENDS = "linux-libc-headers"
+PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+
+PACKAGES = ""
+PACKAGES_DYNAMIC = ""
+
+do_configure () {
+       sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
+       chmod +x ${S}/configure
+       CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
+               --without-cvs --disable-sanity-checks \
+               --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
+               --enable-hacker-mode
+       if grep -q GLIBC_2.3 ${S}/ChangeLog; then
+               # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
+               # Fortunately, we don't need errlist-compat.c, since we just need .h files,
+               # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
+               # Another workaround might be to tell configure to not use any cross options to $(CC).
+               # The real fix would be to get install-headers to not generate errlist-compat.c.
+               make sysdeps/gnu/errlist.c
+               mkdir -p stdio-common
+               touch stdio-common/errlist-compat.c
+       fi
+}
+
+do_compile () {
+       :
+}
+
+do_stage () {
+       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
+
+       # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
+       # so do them by hand.  We can tolerate an empty stubs.h for the moment.
+       # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
+       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
+       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
+       cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
+}
+
+do_install () {
+       :
+}
index 861478f7d5c4848d66cba32b00c78d73d0064aa3..d3dc4b587ac2c92e4460480e6dcaae8395fe2a7b 100644 (file)
@@ -1,47 +1,3 @@
-SECTION = "libs"
 require glibc_${PV}.bb
+require glibc-initial.inc
 
-DEPENDS = "linux-libc-headers"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-PACKAGES = ""
-PACKAGES_DYNAMIC = ""
-
-do_configure () {
-       sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
-       chmod +x ${S}/configure
-       CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
-               --without-cvs --disable-sanity-checks \
-               --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
-               --enable-hacker-mode
-       if grep -q GLIBC_2.3 ${S}/ChangeLog; then
-               # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
-               # Fortunately, we don't need errlist-compat.c, since we just need .h files, 
-               # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
-               # Another workaround might be to tell configure to not use any cross options to $(CC).
-               # The real fix would be to get install-headers to not generate errlist-compat.c.
-               make sysdeps/gnu/errlist.c
-               mkdir -p stdio-common
-               touch stdio-common/errlist-compat.c
-       fi
-}
-
-do_compile () {
-       :
-}
-
-do_stage () {
-       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
-
-       # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
-       # so do them by hand.  We can tolerate an empty stubs.h for the moment.
-       # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
-       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h  ${STAGING_DIR}/${HOST_SYS}/include/features.h
-}
-
-do_install () {
-       :
-}
index 0323debbdd6b4acdf116e40d64e51e1516223d6d..d3dc4b587ac2c92e4460480e6dcaae8395fe2a7b 100644 (file)
@@ -1,46 +1,3 @@
 require glibc_${PV}.bb
+require glibc-initial.inc
 
-DEPENDS = "linux-libc-headers"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-PACKAGES = ""
-PACKAGES_DYNAMIC = ""
-
-do_configure () {
-       sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
-       chmod +x ${S}/configure
-       CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
-               --without-cvs --disable-sanity-checks \
-               --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
-               --enable-hacker-mode
-       if grep -q GLIBC_2.3 ${S}/ChangeLog; then
-               # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
-               # Fortunately, we don't need errlist-compat.c, since we just need .h files, 
-               # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
-               # Another workaround might be to tell configure to not use any cross options to $(CC).
-               # The real fix would be to get install-headers to not generate errlist-compat.c.
-               make sysdeps/gnu/errlist.c
-               mkdir -p stdio-common
-               touch stdio-common/errlist-compat.c
-       fi
-}
-
-do_compile () {
-       :
-}
-
-do_stage () {
-       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
-
-       # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
-       # so do them by hand.  We can tolerate an empty stubs.h for the moment.
-       # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
-       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
-}
-
-do_install () {
-       :
-}
index 6fe67083ec2f389104508056dadbbf3b893df59f..d3dc4b587ac2c92e4460480e6dcaae8395fe2a7b 100644 (file)
@@ -1,47 +1,3 @@
-SECTION = "libs"
 require glibc_${PV}.bb
+require glibc-initial.inc
 
-DEPENDS = "linux-libc-headers"
-PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-2.4', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-PACKAGES = ""
-PACKAGES_DYNAMIC = ""
-
-do_configure () {
-       sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
-       chmod +x ${S}/configure
-       CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
-               --without-cvs --disable-sanity-checks \
-               --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
-               --enable-hacker-mode
-       if grep -q GLIBC_2.3 ${S}/ChangeLog; then
-               # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
-               # Fortunately, we don't need errlist-compat.c, since we just need .h files, 
-               # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
-               # Another workaround might be to tell configure to not use any cross options to $(CC).
-               # The real fix would be to get install-headers to not generate errlist-compat.c.
-               make sysdeps/gnu/errlist.c
-               mkdir -p stdio-common
-               touch stdio-common/errlist-compat.c
-       fi
-}
-
-do_compile () {
-       :
-}
-
-do_stage () {
-       oe_runmake cross-compiling=yes install_root=${STAGING_DIR}/${HOST_SYS} includedir=/include prefix="" install-headers
-
-       # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
-       # so do them by hand.  We can tolerate an empty stubs.h for the moment.
-       # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
-       mkdir -p ${STAGING_DIR}/${HOST_SYS}/include/gnu
-       touch ${STAGING_DIR}/${HOST_SYS}/include/gnu/stubs.h
-       cp ${S}/include/features.h ${STAGING_DIR}/${HOST_SYS}/include/features.h
-}
-
-do_install () {
-       :
-}