]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-doc-utils: Add -nonet option to xsltproc
authorScott Garman <scott.a.garman@intel.com>
Thu, 5 May 2011 04:23:35 +0000 (21:23 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 May 2011 10:54:46 +0000 (11:54 +0100)
This adds the -nonet option to xsltproc invocations, which fixes
compile errors when building gnome-doc-xslt-de.omf.

Also add intltool-native to DEPENDS, which was discovered to be
needed when building this recipe.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-gnome/gnome/gnome-doc-utils.inc
meta/recipes-gnome/gnome/gnome-doc-utils/xsltproc_nonet.patch [new file with mode: 0644]
meta/recipes-gnome/gnome/gnome-doc-utils_0.20.5.bb

index 30cff36dddee8ee1cde2dcc1154346fe34fe600b..903d0806fa7f9b1d69e97ef43dc204344159cd95 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPL LGPL"
 DEPENDS = "libxml2 libxslt libxslt-native gnome-doc-utils-native"
-DEPENDS_virtclass-native = "libxml2-native libxslt-native"
+DEPENDS_virtclass-native = "libxml2-native libxslt-native intltool-native"
 
 inherit gnome gettext
 
diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils/xsltproc_nonet.patch b/meta/recipes-gnome/gnome/gnome-doc-utils/xsltproc_nonet.patch
new file mode 100644 (file)
index 0000000..73d22bf
--- /dev/null
@@ -0,0 +1,34 @@
+This adds the -nonet option to xsltproc invocations, which fixes
+compile errors when building gnome-doc-xslt-de.omf.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+diff -urN gnome-doc-utils-0.20.5.orig//doc/xslt/Makefile.am gnome-doc-utils-0.20.5/doc/xslt/Makefile.am
+--- gnome-doc-utils-0.20.5.orig//doc/xslt/Makefile.am  2011-03-22 06:56:17.000000000 -0700
++++ gnome-doc-utils-0.20.5/doc/xslt/Makefile.am        2011-05-04 21:03:29.382491164 -0700
+@@ -21,14 +21,14 @@
+ $(xsldoc_docs): $(xsldoc_xsls) xsldoc.awk xsldoc-fill.xsl
+       $(GDU_AWK) -f "$(srcdir)/xsldoc.awk" "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))" \
+-      | xsltproc -o "$@" \
++      | xsltproc -nonet -o "$@" \
+       --stringparam basename "$(basename $(notdir $@))" \
+       --stringparam xsl_file "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))" \
+       "$(srcdir)/xsldoc-fill.xsl" -
+ $(xsldoc_xmls): xsldoc-docbook.xsl
+ $(xsldoc_xmls): C/%.xml : C/%.xsldoc
+-      xsltproc -o "$@" \
++      xsltproc -nonet -o "$@" \
+       --stringparam basename "$(basename $(notdir $@))" \
+       --stringparam xsl_file "$(filter %/$(basename $(notdir $@)).xsl,$(xsldoc_xsls))" \
+       "$(srcdir)/xsldoc-docbook.xsl" "$<"
+@@ -75,4 +75,4 @@
+ DOC_MODULE = gnome-doc-xslt
+ DOC_INCLUDES = legal.xml translating.xml $(patsubst %,%.xml,$(xsldoc_base))
+-DOC_LINGUAS = de
+\ No newline at end of file
++DOC_LINGUAS = de
index 94b5aecef632c9f9d32d177387267d7a7b69b0f4..1c864b2296651566185e8b5de4f3e7520bfed31e 100644 (file)
@@ -1,7 +1,9 @@
 require gnome-doc-utils.inc
 LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=eb723b61539feef013de476e68b5c50a \
                    file://COPYING.LGPL;md5=a6f89e2100d9b6cdffcea4f398e37343"
-PR = "r0"
+PR = "r1"
+
+SRC_URI += "file://xsltproc_nonet.patch"
 
 SRC_URI[archive.md5sum] = "3aa1f651834714090cdbf898ec090a98"
 SRC_URI[archive.sha256sum] = "08d99b8ab813fadd3407873e4a30282debce92e22eb1b45430a8bb9c120e2130"