]> code.ossystems Code Review - openembedded-core.git/commitdiff
expat: refresh patches
authorRoss Burton <ross.burton@intel.com>
Thu, 8 Mar 2018 18:17:23 +0000 (20:17 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Mar 2018 17:15:58 +0000 (09:15 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/expat/expat/autotools.patch

index 3d3c5bad9d674b1346993a72185db55ab99ded4a..104717eabb744e42fd199fb752fd41d82f68fac3 100644 (file)
@@ -10,11 +10,12 @@ Updated to apply over expat 2.1.0
 
 Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
 
-diff -Nurd expat-2.1.0/configure.in expat-2.1.0/configure.in
---- expat-2.1.0/configure.ac   2012-03-04 01:45:53.000000000 +0200
-+++ expat-2.1.0/configure.ac   2012-05-10 21:04:44.000000000 +0300
-@@ -51,8 +51,6 @@
+Index: expat-2.2.5/configure.ac
+===================================================================
+--- expat-2.2.5.orig/configure.ac
++++ expat-2.2.5/configure.ac
+@@ -53,8 +53,6 @@ LIBAGE=6       # CMakeLists.txt!
+ CPPFLAGS="${CPPFLAGS} -DHAVE_EXPAT_CONFIG_H"
  AC_CONFIG_HEADER(expat_config.h)
  
 -sinclude(conftools/ac_c_bigendian_cross.m4)