]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Add lastb to alternatives
authorBryan Evenson <bevenson@melinkcorp.com>
Mon, 20 Apr 2015 15:07:37 +0000 (11:07 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 Apr 2015 06:19:03 +0000 (07:19 +0100)
SysVinit creates lastb as a symlink to last during the build.
Just as other applications may provide last, other applications
may provide lastb.

Add alternatives designations for lastb to avoid installation
conflicts with other applications.

Signed-off-by: Bryan Evenson <bevenson@melinkcorp.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb

index 00d333323eb6dec34c62d3fb6e5d7d327d495609..2c7e3ce6c2cf1295f61c2ecb10a21c535eafc32a 100644 (file)
@@ -29,7 +29,7 @@ B = "${S}/src"
 inherit update-alternatives
 DEPENDS_append = " update-rc.d-native base-passwd"
 
-ALTERNATIVE_${PN} = "init mountpoint halt reboot runlevel shutdown poweroff last mesg utmpdump wall"
+ALTERNATIVE_${PN} = "init mountpoint halt reboot runlevel shutdown poweroff last lastb mesg utmpdump wall"
 
 ALTERNATIVE_PRIORITY = "200"