]> code.ossystems Code Review - openembedded-core.git/commitdiff
ofono: Move bluetooth enabling to .inc file
authorJukka Rissanen <jukka.rissanen@linux.intel.com>
Thu, 1 Aug 2013 15:01:38 +0000 (18:01 +0300)
committerSaul Wold <sgw@linux.intel.com>
Fri, 2 Aug 2013 15:21:17 +0000 (08:21 -0700)
Moving the bluetooth enabling to ofono.inc from .bb file as
it makes more sense to have bluetooth always checked.

Signed-off-by: Jukka Rissanen <jukka.rissanen@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/ofono/ofono.inc
meta/recipes-connectivity/ofono/ofono_1.12.bb
meta/recipes-connectivity/ofono/ofono_git.bb

index b0e80200e471d4d78b683fd8bcbf057fa4adab90..7adc667f991a60bd3ef693431bc7aa8f1cf3918a 100644 (file)
@@ -14,6 +14,7 @@ INITSCRIPT_PARAMS = "defaults 22"
 
 EXTRA_OECONF += "\
     ${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdunitdir=${systemd_unitdir}/system/', '--with-systemdunitdir=', d)} \
+    ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
 "
 SYSTEMD_SERVICE_${PN} = "ofono.service"
 
index 44ab0a6dd89b8c0afc93c5173a36fa61c11c077a..32c8bc25cd8cd66625315104dcc80c3cf6d286b4 100644 (file)
@@ -14,6 +14,5 @@ SRC_URI[sha256sum] = "733b75bfd1b2a1925b6de532989c496b8ae17a746691120ef64cceb00b
 
 EXTRA_OECONF += "\
     --enable-test \
-    ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
 "
 CFLAGS_append_libc-uclibc = " -D_GNU_SOURCE"
index f79f34f37dfe2506d356aeffb1ec7cb9acfc390a..db0bf735b662ca7e6f218b4434d302071448ca30 100644 (file)
@@ -8,10 +8,6 @@ PR = "r5"
 SRC_URI  = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
            file://ofono"
 
-EXTRA_OECONF += "\
-    ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
-"
-
 do_configure_prepend () {
   ${S}/bootstrap
 }