]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: depend on libgcrypt
authorEnrico Scholz <enrico.scholz@sigma-chemnitz.de>
Thu, 18 Apr 2013 18:22:46 +0000 (20:22 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Apr 2013 19:57:30 +0000 (20:57 +0100)
Although libgcrypt support is optional, its development files are
are always required to expand AM_PATH_LIBGCRYPT.  Build might fails else
with

| libtoolize: copying file `m4/lt~obsolete.m4'
| configure.ac:446: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
| ...
| configure.ac:446: error: possibly undefined macro: AM_PATH_LIBGCRYPT
| autoreconf: .../autoconf failed with exit status: 1
| + bbfatal 'autoreconf execution failed.'
| + echo 'ERROR: autoreconf execution failed.'

Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_199.bb

index 159dfd8b86c7a468eecd2f81f3d4a91b7787b130..43463c56fb92dc690348137d789744ef7af40165 100644 (file)
@@ -50,6 +50,9 @@ GTKDOC_DOCDIR = "${S}/docs/"
 PACKAGECONFIG ??= "xz"
 # Sign the journal for anti-tampering
 PACKAGECONFIG[gcrypt] = "--enable-gcrypt,--disable-gcrypt,libgcrypt"
+# regardless of PACKAGECONFIG, libgcrypt is always required to expand
+# the AM_PATH_LIBGCRYPT autoconf macro
+DEPENDS += "libgcrypt"
 # Compress the journal
 PACKAGECONFIG[xz] = "--enable-xz,--disable-xz,xz"