]> code.ossystems Code Review - openembedded-core.git/commitdiff
setserial: add patch to fix missing stdlib header
authorSaul Wold <Saul.Wold@intel.com>
Thu, 2 Sep 2010 21:17:27 +0000 (14:17 -0700)
committerSaul Wold <Saul.Wold@intel.com>
Thu, 2 Sep 2010 22:19:34 +0000 (15:19 -0700)
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/recipes-bsp/setserial/setserial/add_stdlib.patch [new file with mode: 0644]
meta/recipes-bsp/setserial/setserial_2.17.bb

diff --git a/meta/recipes-bsp/setserial/setserial/add_stdlib.patch b/meta/recipes-bsp/setserial/setserial/add_stdlib.patch
new file mode 100644 (file)
index 0000000..6a9ebb7
--- /dev/null
@@ -0,0 +1,16 @@
+# This patch addes stdlib.h to fix compiler warnings due to the exit
+# built-in not being defined and getting an incorrect implicit definition
+
+Created-by: Saul Wold <saul.wold@intel.com>
+
+--- setserial-2.17/setserial.c 2010-09-02 14:11:27.569763088 -0700
++++ setserial-2.17_fixed/setserial.c   2010-09-02 14:11:08.546264139 -0700
+@@ -11,6 +11,7 @@
+  */
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <fcntl.h>
+ #include <termios.h>
+ #include <string.h>
+
index 4e0d1b66e4339ce45decfd34d502dda957c5d517..29fc59beb601c0c4724ae3fda8cb627b57458077 100644 (file)
@@ -3,11 +3,13 @@ HOMEPAGE = "http://setserial.sourceforge.net"
 AUTHOR = "Theodore Ts'o <tytso@mit.edu>"
 SECTION = "console/utils"
 LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
 
 inherit autotools
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${PN}-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${PN}-${PV}.tar.gz \
+           file://add_stdlib.patch \
+          "
 
 do_install() {
     install -d ${D}${bindir}