]> code.ossystems Code Review - openembedded-core.git/commitdiff
mkelfimage: fix owner for /usr/sbin/mkelfImage
authorRobert Yang <liezhi.yang@windriver.com>
Wed, 16 Sep 2015 06:08:17 +0000 (23:08 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Sep 2015 20:38:24 +0000 (21:38 +0100)
Fixed:
packages-split/mkelfimage/usr/sbin/mkelfImage is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]

This is because its Makefile uses cp -a to install mkelfImage.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-devtools/mkelfimage/mkelfimage_git.bb

index 2845b8cc3b7fee53a4da0ca7ba3e56a42f49b6fe..e1c33a631be4ec2bfba0d992f55816d635368a31 100644 (file)
@@ -30,6 +30,7 @@ inherit autotools-brokensep
 do_install_append() {
        rmdir ${D}${datadir}/mkelfImage/elf32-i386
        rmdir ${D}${datadir}/mkelfImage
+       chown root:root ${D}/${sbindir}/mkelfImage
 }
 
 BBCLASSEXTEND = "native"