]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Fix linking of the native package on Fedora 13
authorJoshua Lock <josh@linux.intel.com>
Tue, 15 Jun 2010 11:22:01 +0000 (12:22 +0100)
committerJoshua Lock <josh@linux.intel.com>
Tue, 15 Jun 2010 11:33:11 +0000 (12:33 +0100)
Fedora 13 switched the default behaviour of the linker to no longer
indirectly link to required libraries (i.e. dependencies of a library
already linked to). Therefore we need to explicitly pass the depended on
libraries into the linker for building to work on Fedora 13.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/packages/qemu/qemu-0.12.4/linker-flags.patch [new file with mode: 0644]
meta/packages/qemu/qemu.inc
meta/packages/qemu/qemu_0.12.4.bb
meta/packages/qemu/qemu_git.bb

diff --git a/meta/packages/qemu/qemu-0.12.4/linker-flags.patch b/meta/packages/qemu/qemu-0.12.4/linker-flags.patch
new file mode 100644 (file)
index 0000000..7b33aa4
--- /dev/null
@@ -0,0 +1,22 @@
+Fedora 13 switched the default behaviour of the linker to no longer
+indirectly link to required libraries (i.e. dependencies of a library
+already linked to). Therefore we need to explicitly pass the depended on
+libraries into the linker for building to work on Fedora 13.
+
+More information is available on the Fedora Wiki:
+https://fedoraproject.org/wiki/UnderstandingDSOLinkChange
+
+JL - 15/06/10
+Index: qemu-0.12.4/Makefile.target
+===================================================================
+--- qemu-0.12.4.orig/Makefile.target   2010-06-15 11:21:52.000000000 +0100
++++ qemu-0.12.4/Makefile.target        2010-06-15 11:25:27.212852910 +0100
+@@ -178,7 +178,7 @@
+ obj-y += virtio-blk.o virtio-balloon.o virtio-net.o virtio-console.o virtio-pci.o
+ obj-$(CONFIG_KVM) += kvm.o kvm-all.o
+ obj-$(CONFIG_ISA_MMIO) += isa_mmio.o
+-LIBS+=-lz
++LIBS+=-lz -lX11 -ldl
+ sound-obj-y =
+ sound-obj-$(CONFIG_SB16) += sb16.o
index 0a0de2cc4cfe73406c7049a8bb591a99ef32955d..c744990d0fa73b48e417b8845054f2e71d2a9bf5 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://qemu.org"
 LICENSE = "GPL"
 DEPENDS = "zlib"
 
-EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls --extra-ldflags=-ldl"
+EXTRA_OECONF = "--target-list=arm-linux-user,arm-softmmu,i386-softmmu,x86_64-softmmu,mips-linux-user,mips-softmmu --disable-werror --disable-vnc-tls"
 #EXTRA_OECONF += "--disable-sdl"
 
 inherit autotools
index 43a40c2a27c19918345dc4f0ab792e301c37b134..79b73d38ad75ecc6e7b3684c28e227b0034568c2 100644 (file)
@@ -1,17 +1,18 @@
 require qemu.inc
 
-PR = "r13"
+PR = "r14"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
 
 SRC_URI = "\
     http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz \
-    file://workaround_bad_futex_headers.patch;patch=1 \
-    file://qemu-git-qemugl-host.patch;patch=1 \
-    file://no-strip.patch;patch=1 \
-    file://fix-dirent.patch;patch=1 \
-    file://fix-nogl.patch;patch=1 \
-    file://qemugl-allow-glxcontext-release.patch;patch=1"
+    file://workaround_bad_futex_headers.patch \
+    file://qemu-git-qemugl-host.patch \
+    file://no-strip.patch \
+    file://fix-dirent.patch \
+    file://fix-nogl.patch \
+    file://qemugl-allow-glxcontext-release.patch \
+    file://linker-flags.patch"
 
 S = "${WORKDIR}/qemu-${PV}"
index 8f39f5b6f81b8d4db39ba674b7a5220ade39669c..b1468704ac696bb6397716d187423ca398193772 100644 (file)
@@ -1,19 +1,20 @@
 require qemu.inc
 
 PV = "0.12.4"
-PR = "r7"
+PR = "r8"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
 FILESDIR = "${WORKDIR}"
 
 SRC_URI = "\
     git://git.sv.gnu.org/qemu.git;protocol=git \
-    file://workaround_bad_futex_headers.patch;patch=1 \
-    file://qemu-git-qemugl-host.patch;patch=1 \
-    file://no-strip.patch;patch=1 \
-    file://fix-dirent.patch;patch=1 \
-    file://fix-nogl.patch;patch=1 \
-    file://qemugl-allow-glxcontext-release.patch;patch=1"
+    file://workaround_bad_futex_headers.patch \
+    file://qemu-git-qemugl-host.patch \
+    file://no-strip.patch \
+    file://fix-dirent.patch \
+    file://fix-nogl.patch \
+    file://qemugl-allow-glxcontext-release.patch \
+    file://linker-flags.patch"
 
 S = "${WORKDIR}/git"