]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysvinit: Remove ${B} assignment
authorMichael Gloff <mgloff@emacinc.com>
Sat, 12 Sep 2020 22:39:17 +0000 (17:39 -0500)
committerSteve Sakoman <steve@sakoman.com>
Mon, 14 Sep 2020 14:49:12 +0000 (04:49 -1000)
The VERSION variable is not set unless the
top level Makefile is used as the version is
derived from the Changelog.
If VERSION is not set, none of the binaries built
in the sysvinit recipe will have a valid version
output.
Before:
INIT: version  booting
After:
INIT: version 2.96 booting

Using the top level Makefile does not cause any
additional builds to occur.

Signed-off-by: Michael Gloff <mgloff@emacinc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 10992ad4f343d0f92d9d6246cc2e58effd3f3eeb)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-core/sysvinit/sysvinit_2.96.bb

index d2b85ed9c0a0695db9577149948426b53dafaa2a..7358f02385b1de53b6cf1b58c90ec2b19d6020d4 100644 (file)
@@ -25,7 +25,6 @@ SRC_URI[md5sum] = "48cebffebf2a96ab09bec14bf9976016"
 SRC_URI[sha256sum] = "2a2e26b72aa235a23ab1c8471005f890309ce1196c83fbc9413c57b9ab62b587"
 
 S = "${WORKDIR}/sysvinit-${PV}"
-B = "${S}/src"
 
 inherit update-alternatives features_check
 DEPENDS_append = " update-rc.d-native base-passwd virtual/crypt"