]> code.ossystems Code Review - openembedded-core.git/commitdiff
Rename the ui 'init' method to 'main'
authorChris Larson <chris_larson@mentor.com>
Thu, 9 Dec 2010 19:05:22 +0000 (14:05 -0500)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 4 Jan 2011 14:46:47 +0000 (14:46 +0000)
As these may run the UI in a blocking fashion and then return the exit code,
'init' was an inappropriate name, and 'main' is more appropriate.

(Bitbake rev: 4d081a0ed759bd526ab01849d650bd9e8d80ddd1)

Signed-off-by: Chris Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
bitbake/bin/bitbake
bitbake/lib/bb/ui/depexp.py
bitbake/lib/bb/ui/goggle.py
bitbake/lib/bb/ui/knotty.py
bitbake/lib/bb/ui/ncurses.py
bitbake/lib/bb/ui/puccho.py

index 1dbaf96b41abc6afd8c9dadd9ede46e21511a28d..51cb87e28561c8384ec9ef979a87965af47603b1 100755 (executable)
@@ -46,9 +46,6 @@ __version__ = "1.11.0"
 logger = logging.getLogger("BitBake")
 
 
-#============================================================================#
-# BBOptions
-#============================================================================#
 class BBConfiguration(object):
     """
     Manages build options and configurations for one run
@@ -89,13 +86,8 @@ warnings.filterwarnings("ignore", category=PendingDeprecationWarning)
 warnings.filterwarnings("ignore", category=ImportWarning)
 warnings.filterwarnings("ignore", category=DeprecationWarning, module="<string>$")
 
-#============================================================================#
-# main
-#============================================================================#
 
 def main():
-    return_value = 1
-
     parser = optparse.OptionParser(
         version = "BitBake Build Tool Core version %s, %%prog version %s" % (bb.__version__, __version__),
         usage = """%prog [options] [package ...]
@@ -190,7 +182,6 @@ Default BBFILES are the .bb files in the current directory.""")
     bb.utils.clean_environment()
 
     cooker = bb.cooker.BBCooker(configuration, server)
-
     cooker.parseCommandLine()
 
     serverinfo = server.BitbakeServerInfo(cooker.server)
@@ -201,7 +192,7 @@ Default BBFILES are the .bb files in the current directory.""")
     logger.removeHandler(loghandler)
 
     # Setup a connection to the server (cooker)
-    serverConnection = server.BitBakeServerConnection(serverinfo)
+    server_connection = server.BitBakeServerConnection(serverinfo)
 
     # Launch the UI
     if configuration.ui:
@@ -214,17 +205,15 @@ Default BBFILES are the .bb files in the current directory.""")
             # Dynamically load the UI based on the ui name. Although we
             # suggest a fixed set this allows you to have flexibility in which
             # ones are available.
-            uimodule = __import__("bb.ui", fromlist = [ui])
-            ui_init = getattr(uimodule, ui).init
+            module = __import__("bb.ui", fromlist = [ui])
+            ui_main = getattr(module, ui).main
         except AttributeError:
             print("FATAL: Invalid user interface '%s' specified. " % ui)
             print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
         else:
-            return_value = server.BitbakeUILauch().launch(serverinfo, ui_init, serverConnection.connection, serverConnection.events)
+            return server.BitbakeUILauch().launch(serverinfo, ui_main, server_connection.connection, server_connection.events)
     finally:
-        serverConnection.terminate()
-
-    return return_value
+        server_connection.terminate()
 
 if __name__ == "__main__":
     ret = main()
index 155a892f9fc7f4a7a136a8c2e0a03e7a41e42b82..31004db44abdf712b1291323297317188d58db3e 100644 (file)
@@ -185,7 +185,7 @@ class gtkthread(threading.Thread):
         gtk.main()
         gtkthread.quit.set()
 
-def init(server, eventHandler):
+def main(server, eventHandler):
 
     try:
         cmdline = server.runCommand(["getCmdLineAction"])
index 858ca14c4518cc98895ceb833b7e4ccbe134cf7c..40923ba88d7ec61e9d9ca29cdb49a2805463eae4 100644 (file)
@@ -49,7 +49,7 @@ class MainWindow (gtk.Window):
         self.set_default_size(640, 480)
         scrolled_window.add (self.cur_build_tv)
 
-def init (server, eventHandler):
+def main (server, eventHandler):
     gobject.threads_init()
     gtk.gdk.threads_init()
 
index 21160bff5f09474b5fb87927edba609cc5fa1dba..9385883ea95c2694628a9bf1b3b092f007caba3a 100644 (file)
@@ -66,7 +66,7 @@ class BBLogFormatter(logging.Formatter):
         else:
             return logging.Formatter.format(self, record)
 
-def init(server, eventHandler):
+def main(server, eventHandler):
 
     # Get values of variables which control our output
     includelogs = server.runCommand(["getVariable", "BBINCLUDELOGS"])
index 3fed4c58a884a9bd16b066de1ee9356fe9b8d917..3bc8373964641b3f5d05352546c52fe449203fb3 100644 (file)
@@ -324,7 +324,7 @@ class NCursesUI:
                 shutdown = shutdown + 1
                 pass
 
-def init(server, eventHandler):
+def main(server, eventHandler):
     if not os.isatty(sys.stdout.fileno()):
         print("FATAL: Unable to run 'ncurses' UI without a TTY.")
         return
index a627fc803f25a786bdfa9a68baab6d87321500c4..3ce4590c1621ff369ac8ea7896d1341e1baa4059 100644 (file)
@@ -390,7 +390,7 @@ def running_build_failed_cb (running_build, manager):
     print("build failed")
     manager.notify_build_failed ()
 
-def init (server, eventHandler):
+def main (server, eventHandler):
     # Initialise threading...
     gobject.threads_init()
     gtk.gdk.threads_init()