]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-external-tarball: Modernise and rename
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jun 2013 11:05:01 +0000 (11:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jun 2013 15:46:25 +0000 (16:46 +0100)
The external-python-tarball was intended to provide python for those users who
didn't have python 2.6. It has been unloved for a while so this refreshes
it a bit. Specifically:

* Include git and tar since these can have version issues on some systems
* Rename to buildtools-tarball to better reflect its purpose
* Remove the site-config file from the tarball, its pointless
* Prune down the environment file to just cover PATH and OECORE_NATIVE
  (which is needed to correctly install the tarball)
* Add missing grp module (used by do_package) from the unixadmin package

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/meta/buildtools-tarball.bb [moved from meta/recipes-core/meta/external-python-tarball.bb with 69% similarity]

similarity index 69%
rename from meta/recipes-core/meta/external-python-tarball.bb
rename to meta/recipes-core/meta/buildtools-tarball.bb
index 5f8cc964c15443bd62d8f5c4f54e51bae5b41ac6..076fe36d11c40e3f6fc2666a502efa3acc54c395 100644 (file)
@@ -1,10 +1,8 @@
-DESCRIPTION = "Meta package for building a standalone python tarball"
+DESCRIPTION = "Meta package for building a standalone python tarball and other key build tools"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-PR = "r2"
-
 TOOLCHAIN_TARGET_TASK ?= ""
 
 TOOLCHAIN_HOST_TASK ?= "\
@@ -26,10 +24,13 @@ TOOLCHAIN_HOST_TASK ?= "\
     nativesdk-python-netclient \
     nativesdk-python-netserver \
     nativesdk-python-distutils \
+    nativesdk-python-unixadmin \
     nativesdk-chrpath \
+    nativesdk-tar \
+    nativesdk-git \
     "
 
-TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-python-nativesdk-standalone-${DISTRO_VERSION}"
+TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
 
 RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
 
@@ -37,3 +38,10 @@ EXCLUDE_FROM_WORLD = "1"
 
 inherit meta
 inherit populate_sdk
+
+create_sdk_files_append () {
+       rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config*
+       
+       cat ${SDK_OUTPUT}/${SDKPATH}/environment-setup* | grep " PATH=\|OECORE_NATIVE_SYSROOT" > ${WORKDIR}/envtmp
+       mv ${WORKDIR}/envtmp ${SDK_OUTPUT}/${SDKPATH}/environment-setup*
+}