]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsbtest: fix comparison bashism
authorStefan Stanacar <stefanx.stanacar@intel.com>
Tue, 11 Mar 2014 15:40:09 +0000 (15:40 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 12 Mar 2014 03:24:03 +0000 (20:24 -0700)
== is a bashism use = instead.

Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/lsb/lsbtest/LSB_Test.sh
meta/recipes-extended/lsb/lsbtest_1.0.bb

index 12f00547ae3e16a299f69f975dfafc3979f64622..ab79985b1b8c5e3272c134ed17e1201d877fdb8e 100644 (file)
@@ -272,12 +272,12 @@ then
 fi
 
 if ! `grep -F -q "noarch-suse" ${PLATFORM_FILE}`; then
-       if [ ${ARCH} == i686 ];then
+       if [ ${ARCH} = i686 ];then
                echo "i486-suse" >> ${PLATFORM_FILE}
                echo "i486-noarch" >> ${PLATFORM_FILE}
                echo "i486-pc" >> ${PLATFORM_FILE}
                echo "noarch-suse" >> ${PLATFORM_FILE}
-       elif [ ${ARCH} == x86_64 ]; then
+       elif [ ${ARCH} = x86_64 ]; then
                echo "i486-suse" >> ${PLATFORM_FILE}
                echo "i486-noarch" >> ${PLATFORM_FILE}
                echo "i486-pc" >> ${PLATFORM_FILE}
index a877beb29950340dfd83dc2139438be4b3238b37..f61251e2aa026748185d0693eb4c2d9c839d8061 100644 (file)
@@ -19,15 +19,15 @@ do_install() {
        install -d  ${D}/opt/lsb-test
        install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
        install -m 0644 ${S}/session ${D}/opt/lsb-test/session
-       if [ "${TARGET_ARCH}" == "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ];then
                sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
        fi
-       if [ "${TARGET_ARCH}" == "x86_64" ];then
+       if [ "${TARGET_ARCH}" = "x86_64" ];then
                sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
        fi
-       if [ "${TARGET_ARCH}" == "powerpc" ];then
+       if [ "${TARGET_ARCH}" = "powerpc" ];then
                sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
        fi
@@ -37,7 +37,7 @@ do_install() {
        # in the package_list when MLIB=lib64 is being used.
        # Otherwise, by default, the ppc32 LSB packages
        # will be downloaded by LSB_Test.sh
-       if [ "${TARGET_ARCH}" == "powerpc64" ];then
+       if [ "${TARGET_ARCH}" = "powerpc64" ];then
                if [ "${PN}" != "${BPN}" ];then
                        sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
                        sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session