]> code.ossystems Code Review - openembedded-core.git/commitdiff
git/tar/findutils: Add nativesdk versions
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jun 2013 11:05:20 +0000 (11:05 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Jun 2013 15:46:15 +0000 (16:46 +0100)
We need to be able to generate a standalone tarball containing tar/git so
add nativesdk versions of the appropriate recipes to allow this to be possible.

Tweak the git perl paths to avoid warnings when building the nativesdk version,
ensure the binaries are wrapped correctly and avoid update-alternatives in
nativesdk-tar.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/git/git.inc
meta/recipes-extended/findutils/findutils.inc
meta/recipes-extended/tar/tar.inc

index 9829eec6ec6819b2d806b6e63a956939ce7ad0e6..183a93cde6ba16d0d3eefa03e3c74fee8e55396e 100644 (file)
@@ -31,8 +31,8 @@ do_install () {
 
        # ${libdir} is not applicable here, perl-native files are always
        # installed to /usr/lib on both 32/64 bits targets.
-       rm -rf ${D}/usr/lib/perl-native
-       rmdir ${D}/usr/lib || true
+       rm -rf ${D}${exec_prefix}/lib/perl-native
+       rmdir ${D}${exec_prefix}/lib || true
 }
 
 do_install_append_class-native() {
@@ -41,6 +41,12 @@ do_install_append_class-native() {
                GIT_TEMPLATE_DIR=${STAGING_DATADIR_NATIVE}/git-core/templates
 }
 
+do_install_append_class-nativesdk() {
+       create_wrapper ${D}/${bindir}/git \
+               GIT_EXEC_PATH=${libexecdir}/git-core \
+               GIT_TEMPLATE_DIR=${STAGING_DATADIR_NATIVE}/git-core/templates
+}
+
 FILES_${PN} += "${datadir}/git-core ${libxecdir}/git-core/"
 FILES_${PN}-dbg += "${libexecdir}/git-core/.debug"
 
@@ -78,4 +84,4 @@ PACKAGES =+ "gitweb"
 FILES_gitweb = "${datadir}/gitweb/"
 
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
index 9306786832de101f84735b1b82a7cc1e2174ff59..81e6785f637b36d4d7d58ae86ed7fa4ad604b787 100644 (file)
@@ -21,4 +21,4 @@ ALTERNATIVE_PRIORITY = "100"
 # see diffutils.mk in buildroot)
 EXTRA_OECONF_libc-uclibc = "--without-included-regex"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
index f49c7de4a57651eadad9061ec670ef6319053e7d..abeb8c19ffdb48b8965d7de463cd688246ab5370 100644 (file)
@@ -33,6 +33,10 @@ ALTERNATIVE_PRIORITY = "100"
 
 ALTERNATIVE_${PN} = "tar"
 ALTERNATIVE_${PN}-rmt = "rmt"
+ALTERNATIVE_${PN}_class-nativesdk = ""
+ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
 
 ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
 ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
+
+BBCLASSEXTEND = "nativesdk"