]> code.ossystems Code Review - openembedded-core.git/commitdiff
zlib: obey LDFLAGS for tests
authorChristopher Larson <kergoth@gmail.com>
Wed, 28 May 2014 16:14:29 +0000 (09:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 22 Sep 2014 11:57:11 +0000 (12:57 +0100)
Signed-off-by: Christopher Larson <kergoth@gmail.com>
meta/recipes-core/zlib/zlib-1.2.8/ldflags-tests.patch [new file with mode: 0644]
meta/recipes-core/zlib/zlib_1.2.8.bb

diff --git a/meta/recipes-core/zlib/zlib-1.2.8/ldflags-tests.patch b/meta/recipes-core/zlib/zlib-1.2.8/ldflags-tests.patch
new file mode 100644 (file)
index 0000000..650794f
--- /dev/null
@@ -0,0 +1,45 @@
+Obey LDFLAGS for tests
+
+Signed-off-by: Christopher Larson <chris_larson@mentor.com>
+Upstream-status: Pending
+
+--- zlib-1.2.8.orig/Makefile.in
++++ zlib-1.2.8/Makefile.in
+@@ -26,7 +26,7 @@ CFLAGS=-O
+
+ SFLAGS=-O
+ LDFLAGS=
+-TEST_LDFLAGS=-L. libz.a
++TEST_LDFLAGS=-L. $(LDFLAGS)
+ LDSHARED=$(CC)
+ CPP=$(CC) -E
+
+@@ -176,22 +176,22 @@ placebo $(SHAREDLIBV): $(PIC_OBJS) libz.
+       -@rmdir objs
+
+ example$(EXE): example.o $(STATICLIB)
+-      $(CC) $(CFLAGS) -o $@ example.o $(TEST_LDFLAGS)
++      $(CC) $(CFLAGS) -o $@ example.o $(TEST_LDFLAGS) $(STATICLIB)
+
+ minigzip$(EXE): minigzip.o $(STATICLIB)
+-      $(CC) $(CFLAGS) -o $@ minigzip.o $(TEST_LDFLAGS)
++      $(CC) $(CFLAGS) -o $@ minigzip.o $(TEST_LDFLAGS) $(STATICLIB)
+
+ examplesh$(EXE): example.o $(SHAREDLIBV)
+-      $(CC) $(CFLAGS) -o $@ example.o -L. $(SHAREDLIBV)
++      $(CC) $(CFLAGS) -o $@ example.o $(TEST_LDFLAGS) $(SHAREDLIBV)
+
+ minigzipsh$(EXE): minigzip.o $(SHAREDLIBV)
+-      $(CC) $(CFLAGS) -o $@ minigzip.o -L. $(SHAREDLIBV)
++      $(CC) $(CFLAGS) -o $@ minigzip.o $(TEST_LDFLAGS) $(SHAREDLIBV)
+
+ example64$(EXE): example64.o $(STATICLIB)
+-      $(CC) $(CFLAGS) -o $@ example64.o $(TEST_LDFLAGS)
++      $(CC) $(CFLAGS) -o $@ example64.o $(TEST_LDFLAGS) $(STATICLIB)
+
+ minigzip64$(EXE): minigzip64.o $(STATICLIB)
+-      $(CC) $(CFLAGS) -o $@ minigzip64.o $(TEST_LDFLAGS)
++      $(CC) $(CFLAGS) -o $@ minigzip64.o $(TEST_LDFLAGS) $(STATICLIB)
+
+ install-libs: $(LIBS)
+       -@if [ ! -d $(DESTDIR)$(exec_prefix)  ]; then mkdir -p $(DESTDIR)$(exec_prefix); fi
index bdfa045b7b94f2a27aa1dbfb0a1b5e587577d41b..ca0ba3ff6ee1ee075717e00407c5333e75fb6ddc 100644 (file)
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://zlib.h;beginline=4;endline=23;md5=fde612df1e5933c428b
 SRC_URI = "http://www.zlib.net/${BPN}-${PV}.tar.xz \
            file://remove.ldconfig.call.patch \
            file://Makefile-runtests.patch \
+           file://ldflags-tests.patch \
            file://run-ptest \
            "