]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnss-nis: Limit parse skip only for target recipe on musl
authorKhem Raj <raj.khem@gmail.com>
Wed, 4 Jul 2018 03:51:45 +0000 (20:51 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Jul 2018 23:24:14 +0000 (00:24 +0100)
on the host side we are glibc based therefore some native and nativesdk
recipes might need this package even when we target musl based systems

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/libnss-nis/libnss-nis.bb

index e0f69b02ef593fbbca79301009c40b37285468ef..47447acd6cb7af7d767a90778907dab631c0871f 100644 (file)
@@ -28,9 +28,4 @@ BBCLASSEXTEND += "native nativesdk"
 #
 # We will skip parsing this packagegeoup for non-glibc systems
 #
-python __anonymous () {
-    if d.getVar('TCLIBC') != "glibc":
-        raise bb.parse.SkipRecipe("incompatible with %s C library" %
-                                   d.getVar('TCLIBC'))
-}
-
+COMPATIBLE_HOST_libc-musl = 'null'