]> code.ossystems Code Review - openembedded-core.git/commitdiff
connman: Default to enabling ethernet interfaces
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Dec 2011 16:46:41 +0000 (16:46 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 12 Dec 2011 16:50:21 +0000 (16:50 +0000)
This fixes various qemu image failures where connman has changed its
default and would deconfigure network interfaces causing qemu images
and runtime image testing to fail.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/connman/connman/ethernet_default.patch [new file with mode: 0644]
meta/recipes-connectivity/connman/connman_0.78.bb

diff --git a/meta/recipes-connectivity/connman/connman/ethernet_default.patch b/meta/recipes-connectivity/connman/connman/ethernet_default.patch
new file mode 100644 (file)
index 0000000..d0c05d7
--- /dev/null
@@ -0,0 +1,22 @@
+Default to enabling the ethernet interface. If we don't do this, connman
+will shut down all the networking when it starts without any configuration
+which is usualy not what the users expects. This is particularly
+problematic with our qemu images and runtime testing using qemu.
+
+Upstream Status: Inappropriate [Configuration]
+
+RP 2011/12/12
+
+Index: git/src/storage.c
+===================================================================
+--- git.orig/src/storage.c     2011-12-12 16:14:10.892316565 +0000
++++ git/src/storage.c  2011-12-12 16:14:13.788316431 +0000
+@@ -367,7 +367,7 @@
+                                       "Enable", FALSE);
+               g_key_file_set_boolean(keyfile, "Wired",
+-                                      "Enable", FALSE);
++                                      "Enable", TRUE);
+               g_key_file_set_boolean(keyfile, "3G",
+                                       "Enable", FALSE);
index 378bd9d647e7138d03654e6ef18539c6e8be5926..f36f6707c7fe630418d6ecab116acc065beb2705 100644 (file)
@@ -1,10 +1,11 @@
 require connman.inc
 
-PR = "r3"
+PR = "r4"
 
 # 0.78 tag
 SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"
 SRC_URI  = "git://git.kernel.org/pub/scm/network/connman/connman.git \
             file://add_xuser_dbus_permission.patch \
+            file://ethernet_default.patch \
             file://connman"
 S = "${WORKDIR}/git"