]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add leafpad, a simple gtk text-editor
authorChris Lord <chris@openedhand.com>
Mon, 3 Oct 2005 23:40:20 +0000 (23:40 +0000)
committerChris Lord <chris@openedhand.com>
Mon, 3 Oct 2005 23:40:20 +0000 (23:40 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@112 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/leafpad/files/leafpad.desktop [new file with mode: 0644]
openembedded/packages/leafpad/files/leafpad.png [new file with mode: 0644]
openembedded/packages/leafpad/leafpad_0.8.4.bb [new file with mode: 0644]

diff --git a/openembedded/packages/leafpad/files/leafpad.desktop b/openembedded/packages/leafpad/files/leafpad.desktop
new file mode 100644 (file)
index 0000000..7c75817
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Leafpad
+Exec=/usr/bin/leafpad
+Icon=leafpad.png
+Terminal=false
+Type=Application
+Categories=Utility;PIM;
+SingleInstance=true
+StartupNotify=true
+
diff --git a/openembedded/packages/leafpad/files/leafpad.png b/openembedded/packages/leafpad/files/leafpad.png
new file mode 100644 (file)
index 0000000..c5ee0cf
Binary files /dev/null and b/openembedded/packages/leafpad/files/leafpad.png differ
diff --git a/openembedded/packages/leafpad/leafpad_0.8.4.bb b/openembedded/packages/leafpad/leafpad_0.8.4.bb
new file mode 100644 (file)
index 0000000..6faabec
--- /dev/null
@@ -0,0 +1,20 @@
+LICENSE = "GPLv2"
+DEPENDS = "gtk+"
+SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
+          file://leafpad.desktop \
+          file://leafpad.png"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --enable-chooser --disable-gtktest --disable-print"
+
+do_install_append () {
+        install -d ${D}/${datadir}
+        install -d ${D}/${datadir}/applications
+        install -d ${D}/${datadir}/pixmaps/
+
+        install -m 0644 ${WORKDIR}/leafpad.png ${D}/${datadir}/pixmaps
+        install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
+}
+
+FILES_${PN} += "${datadir}/applications/leafpad.desktop ${datadir}/pixmaps/leafpad.png"