]> code.ossystems Code Review - openembedded-core.git/commitdiff
python*-git: Upgrade to version 2.1.1
authorJose Lamego <jose.a.lamego@linux.intel.com>
Thu, 15 Dec 2016 22:44:45 +0000 (16:44 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 17 Dec 2016 09:56:45 +0000 (09:56 +0000)
Both python-git and python3-git need to be upgraded to latest upstream
version.
This change includes python3 dependencies added and was tested
using qemux86 with core-image-sato.

Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-git.inc
meta/recipes-devtools/python/python-git_2.1.1.bb [moved from meta/recipes-devtools/python/python-git_2.1.0.bb with 100% similarity]
meta/recipes-devtools/python/python3-git_2.1.1.bb [moved from meta/recipes-devtools/python/python3-git_2.1.0.bb with 82% similarity]

index ad41561ad26aef7509e5d32a4b266ce6451a43f2..feddf275b9833769ccc1e5569fa4208c9617d290 100644 (file)
@@ -10,8 +10,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
 
 SRC_URI = "https://files.pythonhosted.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
 
-SRC_URI[md5sum] = "29b1fcf504d080dc7a5e630957e829d7"
-SRC_URI[sha256sum] = "3ebda1e6ff1ef68597e41dcd1b99c2a5ae902f4dc2b22ad3533cc89c32b42aad"
+SRC_URI[md5sum] = "77f8339e68dedb6d7c4e26371a588ed9"
+SRC_URI[sha256sum] = "e96f8e953cf9fee0a7599fc587667591328760b6341a0081ef311a942fc96204"
 
 UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
 UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
similarity index 82%
rename from meta/recipes-devtools/python/python3-git_2.1.0.bb
rename to meta/recipes-devtools/python/python3-git_2.1.1.bb
index c9fe9baa20273e272096c9e3f82891372eb38e66..7a2d452a24252bed40c6bc8bd715b41d658a1b37 100644 (file)
@@ -4,4 +4,4 @@ DEPENDS = "python3-gitdb"
 
 inherit setuptools3
 
-RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient"
+RDEPENDS_${PN} += "python3-gitdb python3-lang python3-io python3-shell python3-math python3-re python3-subprocess python3-stringold python3-unixadmin python3-enum python3-logging python3-datetime python3-netclient python3-unittest python3-argparse"