]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-session-sato: start Sato components
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 10:32:10 +0000 (10:32 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 10:32:10 +0000 (10:32 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4216 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-sato/matchbox-sato/matchbox-session [deleted file]
meta/packages/matchbox-sato/matchbox-session-sato/session [moved from meta/packages/matchbox-sato/matchbox-sato/etc/matchbox/session with 100% similarity, mode: 0644]
meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb [moved from meta/packages/matchbox-sato/matchbox-sato_0.1.bb with 66% similarity]

diff --git a/meta/packages/matchbox-sato/matchbox-sato/matchbox-session b/meta/packages/matchbox-sato/matchbox-sato/matchbox-session
deleted file mode 100644 (file)
index 4d6caa0..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-#
-# Very simple session manager for matchbox tools
-#
-
-# Uncomment below to enable parsing of debian menu entrys
-# export MB_USE_DEB_MENUS=1 
-
-if [ -e $HOME/.matchbox/session ]
-then
-exec $HOME/.matchbox/session
-fi
-
-if [ -e /etc/matchbox/session ]
-then
-exec /etc/matchbox/session
-fi
-
-# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
-# dont exist. 
-
-matchbox-desktop &
-matchbox-panel &
-exec matchbox-window-manager $@
similarity index 66%
rename from meta/packages/matchbox-sato/matchbox-sato_0.1.bb
rename to meta/packages/matchbox-sato/matchbox-session-sato_0.1.bb
index b8d6d7151ac08b19a0bc1db02cd043bbd8505b21..e1180ad3011cd1b7754914d1e2b229cd0a47a925 100644 (file)
@@ -1,27 +1,15 @@
 DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
-RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts"
-RCONFLICTS = "matchbox-common"
-PR = "r21"
+RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts matchbox-session"
+PR = "r22"
 
-SRC_URI = "file://etc file://matchbox-session"
-S = ${WORKDIR}
-
-inherit update-alternatives
-
-ALTERNATIVE_NAME = "x-session-manager"
-ALTERNATIVE_LINK = "${bindir}/x-session-manager"
-ALTERNATIVE_PATH = "${bindir}/matchbox-session"
-ALTERNATIVE_PRIORITY = "10"
+SRC_URI = "file://session"
+S = "${WORKDIR}"
 
 do_install() {
-       install -d ${D}/${bindir}
-       install -m 0755 ${S}/matchbox-session ${D}/${bindir}
-       cp -R ${S}/etc ${D}/etc
-       rm -fR ${D}/etc/.svn
-       rm -fR ${D}/etc/matchbox/.svn
-       chmod -R 755 ${D}/etc
+       install -d ${D}/${sysconfdir}/matchbox
+       install -m 0755 ${S}/session ${D}/${sysconfdir}/matchbox/
 }
 
 pkg_postinst_matchbox-sato () {