]> code.ossystems Code Review - openembedded-core.git/commitdiff
qt4: various tidy-ups
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Tue, 6 Dec 2011 12:11:41 +0000 (12:11 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 8 Dec 2011 15:14:05 +0000 (15:14 +0000)
* -reduce-relocations is already specified in qt4.inc, no need to add it
  in qt-${PV}.inc
* Add QT_GLFLAGS to QT_CONFIG_FLAGS in qt4.inc rather than spreading it
  through other inc files.
* Add "-xmlpatterns -no-rpath -qt3support -silent" to QT_CONFIG_FLAGS in
  qt4.inc rather than qt-${PV}.inc; these have been supported since at
  least 4.5.2 and therefore shouldn't be version-specific.
* Move "-no-fast -silent -no-rpath" to EXTRA_OECONF in qt4-native.inc
  rather than the versioned recipes for the same reason
* Remove redundant setting of LICENSE in qt4-embedded.inc

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-qt/qt4/qt-4.7.4.inc
meta/recipes-qt/qt4/qt4-embedded.inc
meta/recipes-qt/qt4/qt4-native.inc
meta/recipes-qt/qt4/qt4-native_4.7.4.bb
meta/recipes-qt/qt4/qt4-x11-free.inc
meta/recipes-qt/qt4/qt4.inc

index 7a3ba54cc8bccb2ea8f95f9bba41ddbad8489dd1..8fda9ce85aafd14541c62b68f090340ac7942af9 100644 (file)
@@ -43,9 +43,6 @@ do_configure_prepend() {
     ${S}/configure
 }
 
-QT_GLFLAGS ?= ""
-QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"
-
 do_compile() {
     # Fixup missing wsegl header in some SGX SDKs
     if ! [ -e ${STAGING_INCDIR}/wsegl.h ] ; then
index c4f6e980d1d7e5ee0b3a75ba37951ac2c5cc51ba..06b2432585c90bf57c4745d53b7661d4836742a8 100644 (file)
@@ -1,9 +1,8 @@
 DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the embedded version."
 SECTION = "libs"
-LICENSE = "LGPLv2.1 | GPLv3"
 HOMEPAGE = "http://qt.nokia.com"
 DEPENDS += "directfb tslib"
-INC_PR = "r37"
+INC_PR = "r38"
 
 QT_BASE_NAME ?= "qt4-embedded"
 QT_BASE_LIB  ?= "libqt-embedded"
index ebbee9be250a4cc9742401ba4311b6db2b89caab..8a6eb4b69b6df1dbd9f6b673ff661568c7490685 100644 (file)
@@ -31,7 +31,8 @@ EXTRA_OECONF = "-prefix ${prefix} \
                 -verbose -release \
                 -embedded -no-freetype -no-glib -no-iconv \
                 -exceptions -xmlpatterns \
-                -qt3support"
+                -qt3support \
+                -no-fast -silent -no-rpath"
 
 # yank default -e, otherwise we get the following error:
 # moc_qbuffer.cpp: No such file or directory
index 3be4d736ebe2947716549e3098361281418317ce..688fb509fb1acc07208a76b15e07e3f9a324172c 100644 (file)
@@ -8,8 +8,6 @@ SRC_URI += "file://blacklist-diginotar-certs.diff \
 # Find the g++.conf/linux.conf in the right directory.
 FILESEXTRAPATHS =. "${FILE_DIRNAME}/qt-${PV}:"
 
-EXTRA_OECONF += " -no-fast -silent -no-rpath"
-
 TOBUILD := "src/tools/bootstrap ${TOBUILD}"
 
 SRC_URI[md5sum] = "9831cf1dfa8d0689a06c2c54c5c65aaf"
index 029c61e447f5e5f70c3eb52589292a4d63f71317..53a44ad6917e9dad48f2d221cb4e386ec97cf89f 100644 (file)
@@ -5,12 +5,12 @@ HOMEPAGE = "http://qt.nokia.com"
 SECTION = "x11/libs"
 DEPENDS += "virtual/libgl virtual/libx11 fontconfig libxft libxext libxrender libxrandr libxcursor"
 
-INC_PR = "r34"
+INC_PR = "r35"
 
 QT_GLFLAGS ?= "${@base_contains('DISTRO_FEATURES', 'opengl', '-opengl', '-no-opengl', d)} "
 QT_GLFLAGS_qemux86 = "-opengl"
 QT_GLFLAGS_qemuppc = "-opengl"
-QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
+QT_CONFIG_FLAGS += "-no-xinerama -no-xkb"
 QT_BASE_NAME ?= "qt4"
 QT_BASE_LIB  ?= "libqt"
 
index bec81b4645e0ffb5fcc0ea196c263e8c2d63d78d..3155cbb6df4cae400f7befd4ff42db9fd0f04bf9 100644 (file)
@@ -11,12 +11,16 @@ QT_DISTRO_FLAGS_linuxstdbase = "-sm"
 
 QT_SQL_DRIVER_FLAGS ?= "-no-sql-ibase -no-sql-mysql -no-sql-psql -no-sql-odbc -plugin-sql-sqlite"
 
+QT_GLFLAGS ?= ""
+
 QT_CONFIG_FLAGS += "-release -no-cups -reduce-relocations \
                     -shared -no-nas-sound -no-nis \
                     -qt-gif -system-libjpeg -system-libpng -system-zlib \
                     -no-pch -qdbus -stl -glib -phonon -webkit \
+                    -xmlpatterns -no-rpath -qt3support -silent \
                     ${QT_SQL_DRIVER_FLAGS} \
-                    ${QT_DISTRO_FLAGS} "
+                    ${QT_DISTRO_FLAGS} \
+                    ${QT_GLFLAGS}"
 
 EXTRA_OEMAKE = "-e"