]> code.ossystems Code Review - openembedded-core.git/commitdiff
fontconfig: enable 64 bit file support
authorSaul Wold <sgw@linux.intel.com>
Fri, 6 Jun 2014 00:09:05 +0000 (17:09 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jun 2014 08:32:25 +0000 (09:32 +0100)
When running 32bit code on a large filessytem with 64bit inodes, the
fontcache was not being created correctly because an EOVERFLOW was being
returned from the fstat when reading the 64 inode on a 32bit system.

The fontcache is created at rootfs time on the host system via qemu.

[YOCTO #6338]

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/fontconfig/fontconfig_2.11.0.bb

index 48385a369a5a2310e53b66a0e1a6bed8080b8b9d..7e8708f8734f2c5f59939c9d7f6837727d3f1235 100644 (file)
@@ -38,5 +38,7 @@ DEBIAN_NOAUTONAME_fontconfig-utils = "1"
 inherit autotools pkgconfig
 
 EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
 
 BBCLASSEXTEND = "native"