]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fixes for Qemu to use VGA and Touch Screen
authorSaul Wold <Saul.Wold@intel.com>
Fri, 4 Jun 2010 22:23:37 +0000 (15:23 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 7 Jun 2010 15:13:00 +0000 (16:13 +0100)
Added usb tablet options to poky-qemu-internal script, and adjusted the
xorg.conf script for x86 to use VGA screen and tablet input device

Signed-off-by: Saul Wold <saul.wold@intel.com>
meta/packages/xorg-xserver/xserver-xf86-config/qemux86/xorg.conf
meta/packages/xorg-xserver/xserver-xf86-config_0.1.bb
scripts/poky-qemu-internal

index 50fd7b4797f59c37088c57ac796c4c3e5f13d0a9..7f5bfa70ea21cc9c088c07e2e56fc8e76ee64342 100644 (file)
@@ -21,6 +21,14 @@ Section "InputDevice"
     Option        "Emulate3Buttons"    "true"
 EndSection
 
+Section "InputDevice"
+    Identifier    "Qemu Tablet"
+    Driver        "evdev"
+    Option        "CorePointer"
+    Option        "Device"        "/dev/input/touchscreen0"
+    Option        "USB"           "on"
+EndSection
+
 Section "Device"
     Identifier    "Graphics Controller"
     Driver        "vmware"
@@ -31,6 +39,14 @@ Section "Monitor"
     Option        "DPMS"
     # 1024x600 59.85 Hz (CVT) hsync: 37.35 kHz; pclk: 49.00 MHz
     Modeline "1024x600_60.00"   49.00  1024 1072 1168 1312  600 603 613 624 -hsync +vsync
+    # 640x480 @ 60Hz (Industry standard) hsync: 31.5kHz
+    ModeLine "640x480"    25.2  640  656  752  800    480  490  492  525 -hsync -vsync
+    # 640x480 @ 72Hz (VESA) hsync: 37.9kHz
+    ModeLine "640x480"    31.5  640  664  704  832    480  489  491  520 -hsync -vsync
+    # 640x480 @ 75Hz (VESA) hsync: 37.5kHz
+    ModeLine "640x480"    31.5  640  656  720  840    480  481  484  500 -hsync -vsync
+    # 640x480 @ 85Hz (VESA) hsync: 43.3kHz
+    ModeLine "640x480"    36.0  640  696  752  832    480  481  484  509 -hsync -vsync
 EndSection
 
 Section "Screen"
@@ -39,7 +55,7 @@ Section "Screen"
     Monitor        "Generic Monitor"
     DefaultDepth    24
     SubSection "Display"
-        Modes     "1024x600_60.00"
+        Modes     "640x480"
     EndSubSection
 EndSection
 
@@ -47,7 +63,7 @@ Section "ServerLayout"
     Identifier    "Default Layout"
     Screen        "Default Screen"
     InputDevice    "Generic Keyboard"
-    InputDevice    "Configured Mouse"
+    # InputDevice    "Configured Mouse"
+    InputDevice    "QEMU Tablet"
     Option         "AllowEmptyInput" "no"
 EndSection
-
index 80c3a2857657522fb9acc9e784b735f49de16aa5..2089e26a63ead0cef5a608df2546ab9f7bd8fd1a 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "X.Org X server configuration file"
 HOMEPAGE = "http://www.x.org"
 SECTION = "x11/base"
 LICENSE = "MIT-X"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "file://xorg.conf"
 
index 7dd52371b621140229d2d345d7c3b08c6d7c91b0..11178a7b5077abdbe575b0650dbebe4002123b2f 100755 (executable)
@@ -48,6 +48,7 @@ KERNEL_NETWORK_CMD="ip=192.168.7.2::192.168.7.1:255.255.255.0"
 QEMU_TAP_CMD="-net tap,vlan=0,ifname=tap0,script=$QEMUIFUP,downscript=$QEMUIFDOWN"
 QEMU_NETWORK_CMD="-net nic,vlan=0 $QEMU_TAP_CMD"
 KERNCMDLINE="mem=$QEMU_MEMORY"
+QEMU_UI_OPTIONS="-show-cursor -usb -usbdevice wacom-tablet"
 
 SERIALOPTS=""
 if [ "x$SERIAL_LOGFILE" != "x" ]; then
@@ -81,9 +82,10 @@ fi
 
 if [ "$MACHINE" = "qemuarm" -o "$MACHINE" = "qemuarmv6" -o "$MACHINE" = "qemuarmv7" ]; then
     QEMU=qemu-system-arm
+    # QEMU_UI_OPTIONS="$QEMU_UI_OPTIONS -force-pointer"
     if [ "$TYPE" = "ext3" ]; then
         KERNCMDLINE="root=/dev/sda console=ttyAMA0 console=tty0 $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
-        QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb -hda $HDIMAGE -usb -usbdevice wacom-tablet -no-reboot -force-pointer -show-cursor"
+        QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb -hda $HDIMAGE -no-reboot $QEMU_UI_OPTIONS"
     fi
     if [ "$TYPE" = "nfs" ]; then
         if [ "x$HDIMAGE" = "x" ]; then
@@ -94,7 +96,7 @@ if [ "$MACHINE" = "qemuarm" -o "$MACHINE" = "qemuarmv6" -o "$MACHINE" = "qemuarm
             return
         fi
         KERNCMDLINE="root=/dev/nfs nfsroot=192.168.7.1:$HDIMAGE rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
-        QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb -usb -usbdevice wacom-tablet -no-reboot -force-pointer -show-cursor"
+        QEMUOPTIONS="$QEMU_NETWORK_CMD -M versatilepb --no-reboot $QEMU_UI_OPTIONS"
     fi
        if [ "$MACHINE" = "qemuarmv6" ]; then
                QEMUOPTIONS="$QEMUOPTIONS -cpu arm1136"
@@ -106,9 +108,10 @@ fi
 
 if [ "$MACHINE" = "qemux86" ]; then
     QEMU=qemu
+    QEMU_UI_OPTIONS="$QEMU_UI_OPTIONS -vga vmware -enable-gl"
     if [ "$TYPE" = "ext3" ]; then
         KERNCMDLINE="vga=0 root=/dev/hda mem=$QEMU_MEMORY $KERNEL_NETWORK_CMD"
-        QEMUOPTIONS="-vga vmware -show-cursor $QEMU_NETWORK_CMD -hda $HDIMAGE -enable-gl"
+        QEMUOPTIONS="$QEMU_NETWORK_CMD -hda $HDIMAGE $QEMU_UI_OPTIONS"
     fi
     if [ "$TYPE" = "nfs" ]; then
         if [ "x$HDIMAGE" = "x" ]; then
@@ -119,7 +122,7 @@ if [ "$MACHINE" = "qemux86" ]; then
             return
         fi
         KERNCMDLINE="root=/dev/nfs nfsroot=192.168.7.1:$HDIMAGE rw $KERNEL_NETWORK_CMD mem=$QEMU_MEMORY"
-        QEMUOPTIONS="-vga vmware -show-cursor $QEMU_NETWORK_CMD -enable-gl"
+        QEMUOPTIONS="$QEMU_NETWORK_CMD $QEMU_UI_OPTIONS"
     fi
 fi