]> code.ossystems Code Review - openembedded-core.git/commitdiff
Don't assume diet-libx11 has been used, check at build time
authorRoss Burton <ross@openedhand.com>
Mon, 20 Mar 2006 12:38:36 +0000 (12:38 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 20 Mar 2006 12:38:36 +0000 (12:38 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@299 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/gtk+/gtk+-2.8.9/no-xwc.patch

index affb4a303e11d440c7ed1179f67bd6306163b675..318b1503597694b1cadd13bd45dc27e844142ac2 100644 (file)
@@ -1,11 +1,31 @@
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c      2004-11-30 14:57:14 +00:00
-+++ gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c       2005-01-02 15:38:06 +00:00
-@@ -576,12 +576,14 @@
+Index: configure.in
+===================================================================
+RCS file: /cvs/gnome/gtk+/configure.in,v
+retrieving revision 1.469.2.22
+diff -u -r1.469.2.22 configure.in
+--- gtk/configure.in   16 Mar 2006 16:39:45 -0000      1.469.2.22
++++ gtk/configure.in   20 Mar 2006 12:07:11 -0000
+@@ -1115,6 +1115,8 @@
+   AC_CHECK_FUNCS(XConvertCase XInternAtoms)
++  AC_CHECK_FUNCS(XmbDrawString)
++
+   # Generic X11R6 check needed for XIM support; we could
+   # probably use this to replace the above, but we'll
+   # leave the separate checks for XConvertCase and XInternAtoms 
+Index: gdk/x11/gdkdrawable-x11.c
+===================================================================
+RCS file: /cvs/gnome/gtk+/gdk/x11/gdkdrawable-x11.c,v
+retrieving revision 1.58
+diff -u -r1.58 gdkdrawable-x11.c
+--- gtk/gdk/x11/gdkdrawable-x11.c      15 Aug 2005 19:04:54 -0000      1.58
++++ gtk/gdk/x11/gdkdrawable-x11.c      20 Mar 2006 12:07:12 -0000
+@@ -579,12 +579,14 @@
                         GDK_GC_GET_XGC (gc), x, y, (XChar2b *) text, text_length / 2);
        }
      }
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
    else if (font->type == GDK_FONT_FONTSET)
      {
        XFontSet fontset = (XFontSet) GDK_FONT_XFONT (font);
@@ -16,15 +36,15 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c gtk+-2.6.0/gdk/
    else
      g_error("undefined font type\n");
  }
-@@ -613,6 +615,7 @@
+@@ -616,6 +618,7 @@
                     GDK_GC_GET_XGC (gc), x, y, text_8bit, text_length);
        g_free (text_8bit);
      }
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
    else if (font->type == GDK_FONT_FONTSET)
      {
        if (sizeof(GdkWChar) == sizeof(wchar_t))
-@@ -633,6 +636,7 @@
+@@ -636,6 +639,7 @@
          g_free (text_wchar);
        }
      }
@@ -32,14 +52,18 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkdrawable-x11.c gtk+-2.6.0/gdk/
    else
      g_error("undefined font type\n");
  }
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/gdkfont-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c  2004-08-26 01:23:46 +01:00
-+++ gtk+-2.6.0/gdk/x11/gdkfont-x11.c   2005-01-02 15:45:39 +00:00
-@@ -525,10 +525,12 @@
+Index: gdk/x11/gdkfont-x11.c
+===================================================================
+RCS file: /cvs/gnome/gtk+/gdk/x11/gdkfont-x11.c,v
+retrieving revision 1.48.2.1
+diff -u -r1.48.2.1 gdkfont-x11.c
+--- gtk/gdk/x11/gdkfont-x11.c  20 Jan 2006 04:39:43 -0000      1.48.2.1
++++ gtk/gdk/x11/gdkfont-x11.c  20 Mar 2006 12:07:12 -0000
+@@ -527,10 +527,12 @@
          width = XTextWidth16 (xfont, (XChar2b *) text, text_length / 2);
        }
        break;
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
      case GDK_FONT_FONTSET:
        fontset = (XFontSet) private->xfont;
        width = XmbTextEscapement (fontset, text, text_length);
@@ -48,15 +72,15 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/
      default:
        width = 0;
      }
-@@ -578,6 +580,7 @@
+@@ -580,6 +582,7 @@
            width = 0;
          }
        break;
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
      case GDK_FONT_FONTSET:
        if (sizeof(GdkWChar) == sizeof(wchar_t))
        {
-@@ -595,6 +598,7 @@
+@@ -597,6 +600,7 @@
          g_free (text_wchar);
        }
        break;
@@ -64,15 +88,15 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/
      default:
        width = 0;
      }
-@@ -667,6 +671,7 @@
+@@ -669,6 +673,7 @@
        if (descent)
        *descent = overall.descent;
        break;
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
      case GDK_FONT_FONTSET:
        fontset = (XFontSet) private->xfont;
        XmbTextExtents (fontset, text, text_length, &ink, &logical);
-@@ -681,6 +686,7 @@
+@@ -683,6 +688,7 @@
        if (descent)
        *descent = ink.y + ink.height;
        break;
@@ -80,15 +104,15 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/
      }
  
  }
-@@ -753,6 +759,7 @@
+@@ -755,6 +761,7 @@
          *descent = overall.descent;
        break;
        }
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
      case GDK_FONT_FONTSET:
        fontset = (XFontSet) private->xfont;
  
-@@ -780,6 +787,7 @@
+@@ -782,6 +789,7 @@
        if (descent)
        *descent = ink.y + ink.height;
        break;
@@ -96,14 +120,18 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkfont-x11.c gtk+-2.6.0/gdk/x11/
      }
  
  }
-diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c gtk+-2.6.0/gdk/x11/gdkim-x11.c
---- ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c    2004-11-17 00:55:10 +00:00
-+++ gtk+-2.6.0/gdk/x11/gdkim-x11.c     2005-01-02 15:42:04 +00:00
+Index: gdk/x11/gdkim-x11.c
+===================================================================
+RCS file: /cvs/gnome/gtk+/gdk/x11/gdkim-x11.c,v
+retrieving revision 1.38
+diff -u -r1.38 gdkim-x11.c
+--- gtk/gdk/x11/gdkim-x11.c    16 Mar 2005 03:17:27 -0000      1.38
++++ gtk/gdk/x11/gdkim-x11.c    20 Mar 2006 12:07:12 -0000
 @@ -48,6 +48,7 @@
  void
  _gdk_x11_initialize_locale (void)
  {
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
    wchar_t result;
    gchar *current_locale;
    static char *last_locale = NULL;
@@ -121,7 +149,7 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c gtk+-2.6.0/gdk/x11/gd
  {
    gchar *mbstr;
  
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
    if (gdk_use_mb)
      {
        GdkDisplay *display = find_a_display ();
@@ -137,7 +165,7 @@ diff -urNd ../gtk+-2.6.0-r2/gtk+-2.6.0/gdk/x11/gdkim-x11.c gtk+-2.6.0/gdk/x11/gd
  gint
  gdk_mbstowcs (GdkWChar *dest, const gchar *src, gint dest_max)
  {
-+#ifdef HAVE_XWC
++#ifdef HAVE_XMBDRAWSTRING
    if (gdk_use_mb)
      {
        GdkDisplay *display = find_a_display ();